AnsweredAssumed Answered

Alfresco Community 4.2.f install problem.  Please help

Question asked by markrwells on Jul 8, 2014
Latest reply on Jul 9, 2014 by markrwells
I have been working on this for a couple weeks now and the recurring issues are driving me crazy. So any help is greatly appreciated. 

OK, the basics for the server are:

Ubuntu 14.04
openjdk 7 jdk is loaded
whereis java and javac work

I have tried 2 different ways with same result.  1. load Alfresco installer straight to server which includes problem and 2. load Libreoffice to server first, then load alfresco installer.  the problem persists no matter what order items are loaded.

whereis soffice works and reports version.

load alfresco installer.  Select Y for all or Select N for Java and LibreOffice doesn't matter. Same problem results.

run alfresco start.

go to web page.  Alfresco and Share both load and run. 

Upload a Word Doc to a new site document library.  Upload a jpeg and upload a pdf file. 

PDF and JPEG can be viewed in the browser and have a thumbnail. 

The Word Doc does not have a thumbnail and cannot be previewed in the browser. 

Now here is the fun part.  Erase everything, start over from scratch, load everything on to the server then use the BITNAMI Alfresco installer instead of the default Alfresco installer. 

Results: all files uploaded to the document repository work fine just like they are suppose to.

Now why don't I just use the BITNAMI install? because the Alfresco Workdesk won't load to the BITNAMI version and I need Workdesk. 

Seems like there has to be a simple answer for this.  The alfresco installer should just work. It should not have this problem right out of the box so to say.  

Outcomes