AnsweredAssumed Answered

Share Preview doesn't show anything

Question asked by timok on Aug 11, 2014
Latest reply on Aug 18, 2014 by timok
Dear Alfresco Community,

I had installed Alfresco 5a CE on my Windows 2008R2 Server.
The System runs well except the Browser Preview of Documents. It doesn't matter if its a .docx oder .pdf, nothing is shown on the Document Details page. The generation of the Thumbnails works.

I think I can see the error in the log-file but can't fix it:
14:31:13,789 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] [http-apr-8080-exec-5] Starting 'Transformers' subsystem, ID: [Transformers, default]
14:31:13,851 ERROR [org.alfresco.repo.content.transform.TransformerConfigDynamicTransformers] [http-apr-8080-exec-5] Cannot create dynamic transformer transformer.complex.JodConverter.Image as sub transformers could not be found or created ("JodConverter.2Pdf|pdf|complex.PDF.Image").
14:31:13,851 ERROR [org.alfresco.repo.content.transform.TransformerConfigDynamicTransformers] [http-apr-8080-exec-5] Cannot create dynamic transformer transformer.complex.JodConverter.Pdf2swf as sub transformers could not be found or created ("JodConverter.2Pdf|pdf|Pdf2swf").
14:31:13,851 ERROR [org.alfresco.repo.content.transform.TransformerConfigDynamicTransformers] [http-apr-8080-exec-5] Cannot create dynamic transformer transformer.JodConverter.Html2Pdf as sub transformers could not be found or created ("JodConverter|odt|JodConverter").
14:31:13,851 ERROR [org.alfresco.repo.content.transform.TransformerConfigDynamicTransformers] [http-apr-8080-exec-5] Cannot create dynamic transformer transformer.JodConverter.2Pdf as sub transformers could not be found or created ("JodConverter|JodConverter.Html2Pdf").
14:31:13,851 ERROR [org.alfresco.repo.content.transform.TransformerConfigDynamicTransformers] [http-apr-8080-exec-5] Cannot create dynamic transformer transformer.complex.JodConverter.PdfBox as sub transformers could not be found or created ("JodConverter.2Pdf|pdf|PdfBox").
14:31:14,070 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] [http-apr-8080-exec-5] Startup of 'Transformers' subsystem, ID: [Transformers, default] complete


It seems that Alfresco can't find the Coverter exe's but the path in the global.properties ist right:
### External executable locations ###
ooo.exe=C:\\Alfresco\\libreoffice\\App\\libreoffice\\program\\soffice.exe
ooo.enabled=true
ooo.port=8100
ooo.host=127.0.0.1
img.root=C:\\Alfresco\\imagemagick
img.coders=${img.root}\\modules\\coders
img.config=${img.root}\\config
img.gslib=${img.root}\\lib
img.exe=${img.root}\\convert.exe
swf.exe=C:\\Alfresco\\swftools\\pdf2swf.exe
swf.languagedir=C:\\Alfresco\\swftools\\japanese
content.transformer.complex.OpenOffice.extensions.docx.pdf.maxSourceSizeKBytes=10240

jodconverter.enabled=false
jodconverter.officeHome=C:\\Alfresco\\libreoffice\\App
jodconverter.portNumbers=2022,2023,2024


Anyone an idea?


Greetings
Timo

Outcomes