AnsweredAssumed Answered

Alfresco 5.0a + proxypass on port 443 + Mobile 1.4.0.217 = 'hostname was not verified'

Question asked by lambrosx on Aug 27, 2014
Latest reply on Sep 4, 2014 by mikeh
Hello Alfresco team,

I'm new here and on Alfresco. This tool is fantastic.

I installed version 5.0.a on a Ubuntu LTS 14.04 with the bin package. Everything is ok. Now, I try to make it accessible from internet over https (with a self signed cert), I use proxy pass on my virtualhost. Everything is ok and accessible with firefox and Android chrome but not with Alfresco Mobile app. I tried manythings without any results.

I printed my logcat and obtain :
org.alfresco.mobile.android.api.exceptions.AlfrescoSessionException: org.apache.chemistry.opencmis.commons.exceptions.CmisConnectionException: Cannot access https://myinterneturl:443/alfresco : Hostname 'myinterneturl' was not verified.


I thought the problem was my self signed cert so i tried to intall it on my smartphone, put myhostname.properties, but nothing.
I tried to force binding URL /alfresco/cmisatom… but nothing.
I tried Apache configuration with mod_jk but nothing. Still working with Android browser but not with the mobile app…

Mobile app only work on port 8080.

Any idea?

Thank you

Outcomes