AnsweredAssumed Answered

Community 4.2.f: lucene index cleaner keeps running

Question asked by hansdebal on Oct 1, 2014
Latest reply on Oct 13, 2014 by hansdebal
Hi,

I upgraded our repository from 4.0.d to 4.2.f. Our index-engine is lucene. I have a cluster of 2 machines. I enabled debugging for log4j.logger.org.alfresco.repo.search.impl.lucene.index.

When I start tomcat and it loads the alfresco-webapp, the index cleaner keeps running and tomcat-startup never gets completed.

2014-10-01 09:59:37,782 DEBUG indexThread8 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 09:59:45,490 DEBUG indexThread9 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 09:59:53,191 DEBUG indexThread10 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 09:59:53,786 DEBUG indexThread1 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 09:59:54,140 DEBUG indexThread7 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 09:59:55,286 DEBUG indexThread6 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 09:59:57,782 DEBUG indexThread3 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:05,490 DEBUG indexThread5 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:13,191 DEBUG indexThread4 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:13,786 DEBUG indexThread2 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:14,141 DEBUG indexThread8 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:15,286 DEBUG indexThread9 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:17,782 DEBUG indexThread10 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:25,490 DEBUG indexThread1 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:33,191 DEBUG indexThread7 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:33,787 DEBUG indexThread6 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:34,141 DEBUG indexThread3 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:35,286 DEBUG indexThread5 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:37,782 DEBUG indexThread4 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:45,490 DEBUG indexThread2 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:53,192 DEBUG indexThread8 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:53,787 DEBUG indexThread9 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:54,141 DEBUG indexThread10 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:55,286 DEBUG indexThread1 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:00:57,782 DEBUG indexThread7 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …
2014-10-01 10:01:05,491 DEBUG indexThread6 [org.alfresco.repo.search.impl.lucene.index.IndexInfo] Index cleaner running …

…..

I already did a full-index which ran for days, but eventualy I killed it, the same issue appeared (Index cleaner running …).

I saw this post https://forums.alfresco.com/forum/installation-upgrades-configuration-integration/installation-upgrades/upgrade-40-42-lucene and this one https://forums.alfresco.com/forum/installation-upgrades-configuration-integration/installation-upgrades/upgrade-40-42-lucene-0 but gthey never got answered. Changing to solr isn't really an option for now because of budget and time-constraints.

Does anyone have solution for this?

Thanks!!

Outcomes