AnsweredAssumed Answered

Unsupported major.minor version 52.0

Question asked by jeremiebal on Oct 29, 2014
Latest reply on Nov 4, 2014 by jeremiebal
Bonjour à tous

Je me casse la tête sur un problème que je ne comprend pas.
Lorsque je crée un JAR sous Eclipse pour le déployer dans Alfresco, il m'indique l'erreur suivante lors du redémarrage du serveur Alfresco :

Caused by: java.lang.UnsupportedClassVersionError: beans/SiteDemoFactureEvaluator : Unsupported major.minor version 52.0

Pourtant, je ne vois pas d'où le conflit de version puisse venir.
Mes versions de JAVA installées :
Alfresco One 4.2 :  Java 1.7
JDK : 1.7
JRE (livré avec JDK) : 1.7
Variables d'environnement pointent vers : 1.7
Eclipse configuré : 1.7
Fichier ANT build.xml : configuré pour être lancé en 1.7

Je tiens à préciser que je n'ai aucuns autres JRE ou JDK d'installés.

La création du JAR se passe sans soucis sous Eclipse mais je ne comprend pas pourquoi Alfresco me parle de ce Major.minor 52.

Je vous remercie par avance d'essayer de m'éclairer sur ce problème.

Outcomes