AnsweredAssumed Answered

ftp connection refused

Question asked by rocketboy2000 on Nov 4, 2014
Latest reply on Nov 5, 2014 by rocketboy2000
I thought I had A.A.A.R. all working… but something seems to have busted.

specifically, when attempting the AAAR_Publish.bat I am getting a problem, I believe, with uploading the reports to alfresco.

I've tested ftp and it is working on port 21 for user admin/admin.



2014/11/04 10:28:19 - Set Variables.0 - Setting environment variables…
2014/11/04 10:28:19 - Set Variables.0 - Set variable http_prpt to value [http://localhost:8081/penta
ho/api/repo/files/:public:AAAR:Reports:audit_use.prpt]
2014/11/04 10:28:19 - Set Variables.0 - Set variable http_login to value [admin]
2014/11/04 10:28:19 - Set Variables.0 - Set variable http_password to value [password]
2014/11/04 10:28:19 - Set Variables.0 - Set variable prpt_path to value [c:\temp\\audit_use.prpt]
2014/11/04 10:28:19 - Set Variables.0 - Set variable extension to value [pdf]
2014/11/04 10:28:19 - Set Variables.0 - Set variable report_regex to value [^audit_use(.+)pdf$]
2014/11/04 10:28:19 - Set Variables.0 - Set variable alfresco_ftp to value [localhost]
2014/11/04 10:28:19 - Set Variables.0 - Set variable alfresco_port to value [121]
2014/11/04 10:28:19 - Set Variables.0 - Set variable alfresco_login to value [admin]
2014/11/04 10:28:19 - Set Variables.0 - Set variable alfresco_password to value [admin]
2014/11/04 10:28:19 - Set Variables.0 - Set variable alfresco_path to value [alfresco]
2014/11/04 10:28:19 - Set Variables.0 - Set variable report_path to value [c:\temp\\audit_use.pdf]
2014/11/04 10:28:19 - Set Variables.0 - Finished after 1 rows.
2014/11/04 10:28:19 - Set Variables.0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
2014/11/04 10:28:19 - Report - Starting entry [HTTP]
2014/11/04 10:28:19 - HTTP - Start of HTTP job entry.
2014/11/04 10:28:19 - HTTP - Connecting to URL: http://localhost:8081/pentaho/api/repo/files/:public
:AAAR:Reports:audit_use.prpt
2014/11/04 10:28:23 - HTTP - Resource type: application/vnd.pentaho.reporting.classic, last modified
on: Wed Dec 31 16:00:00 PST 1969.
2014/11/04 10:28:24 - HTTP - Finished writing 77476 bytes to result file [c:\temp\\audit_use.prpt]
2014/11/04 10:28:24 - Report - Starting entry [Create report]
2014/11/04 10:28:24 - Create report - Dispatching started for transformation [Create report]
2014/11/04 10:28:24 - Generate Rows.0 - Finished processing (I=0, O=0, R=0, W=1, U=0, E=0)
2014/11/04 10:28:24 - Calculator.0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
2014/11/04 10:28:24 - Select values 2.0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
2014/11/04 10:28:24 - Switch / Case.0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
2014/11/04 10:28:29 - Pentaho Reporting for pdf.0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=
0)
2014/11/04 10:28:29 - Dummy (do nothing).0 - Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
2014/11/04 10:28:29 - Report - Starting entry [Delete prpt]
2014/11/04 10:28:29 - Delete prpt - File [c:\temp\\audit_use.prpt] deleted!
2014/11/04 10:28:29 - Report - Starting entry [Carica file con FTP]
2014/11/04 10:28:29 - Carica file con FTP - Using PDIFTPClient override for exists() fix.
2014/11/04 10:28:30 - Carica file con FTP - ERROR (version 5.2.0.0, build 1 from 2014-09-30_19-48-28
by buildguy) : Error putting to FTP : Connection refused: connect
2014/11/04 10:28:30 - Carica file con FTP - ERROR (version 5.2.0.0, build 1 from 2014-09-30_19-48-28
by buildguy) : java.net.ConnectException: Connection refused: connect
2014/11/04 10:28:30 - Carica file con FTP -     at java.net.DualStackPlainSocketImpl.waitForConnect(
Native Method)



I've noticed the "alfresco_port to value [121]"… is that causing the problem? how can I adjust in my kitchen job?

thanks in advance.

Outcomes