AnsweredAssumed Answered

Error during Alfresco Community Edition 5.0.b install - smtp port in use 25

Question asked by ruimota on Nov 5, 2014
Latest reply on Nov 6, 2014 by ruimota
Hello,

I am running a old instalation of Alfresco Community Edition (3.3g) and it has worked fine (Windows Server 2003  Environment) until today.
Since i am having server hardware pre-failures i started looking for a new Alfresco Community version and begun testing 5.0.a.
Unfortunately i had problems on the services startup for alfresco and TomCat, moving towards version 5.0.b.
During the installation of Alfresco Community 5.0.b release i got the following error:

"Warning environment is not configured optimally for Alfresco - please carefully review this list before continuing:
While these issues will not prevent Alfresco from functioning, some product features may be unavailable, or the system may not perform optimally.
SMTP TCP port is use: 25"

I could not find the reason for this error and later ignored it completing the software installation.
All seems to work fine except for the Outbond email (site members invitation) when using port 25 (Exchange Server).
For troubleshooting i tested the following:

1- Tested outbound email service with SMTPS (GMAIL) on port 465 and invitation is sent to destination users.
2- Made a fresh Operating sistem install CentOS 6.5 and after Alfresco Community Edition 5.0.b but got the same warning and error.
3- Made a second fresh Operating System Install CentOS 7 (another server) but again got the same warning and error.

My question is:
Is this error related to release 5.0.b? and if so is there a way to fix it?
The previous version (5.0.a) doesn't return errors on install (CentOS 6 and 7) but services fail on startup (mainly TomCat).

Thanks

Rui

Outcomes