AnsweredAssumed Answered

maven unable to build Alfresco project for 4.2e

Question asked by alfresco-jan on Nov 11, 2014
Latest reply on Nov 21, 2014 by jpotts
Hi everybody,
I am trying to extend my alfresco content model with this tutorial: http://ecmarchitect.com/alfresco-developer-series-tutorials/maven-sdk/tutorial/tutorial.html
Currently I am not able to build alfresco 4.2e via maven. I raised a issue here: https://code.google.com/p/maven-alfresco-archetypes/issues/detail?id=194&sort=-id but no one replied.

Can at least somebody confirm, that this is not working?


Again the steps and the error output from the terminal:








 mvn archetype:generate \
> -DarchetypeCatalog=https://artifacts.alfresco.com/nexus/content/groups/public/archetype-catalog.xml \
> -Dfilter=org.alfresco.maven.archetype:
[INFO] Scanning for projects…
[INFO] Searching repository for plugin with prefix: 'archetype'.
[INFO] ————————————————————————
[INFO] Building Maven Default Project
[INFO]    task-segment: [archetype:generate] (aggregator-style)
[INFO] ————————————————————————
[INFO] Preparing archetype:generate
[INFO] No goals needed for project - skipping
[INFO] [archetype:generate {execution: default-cli}]
[INFO] Generating project in Interactive mode
[INFO] No archetype defined. Using maven-archetype-quickstart (org.apache.maven.archetypes:maven-archetype-quickstart:1.0)
Choose archetype:
1: https://artifacts.alfresco.com/nexus/content/groups/public/archetype-catalog.xml -> org.alfresco.maven.archetype:alfresco-amp-archetype (Sample project with full support for lifecycle and rapid development of AMPs (Alfresco Module Packages))
2: https://artifacts.alfresco.com/nexus/content/groups/public/archetype-catalog.xml -> org.alfresco.maven.archetype:alfresco-allinone-archetype (Sample multi-module project for All-in-One development on the Alfresco plaftorm. Includes modules for: Repository WAR overlay, Repository AMP, Share WAR overlay, Solr configuration, and embedded Tomcat runner)
Choose a number or apply filter (format: [groupId:]artifactId, case sensitive contains): : 1
Choose org.alfresco.maven.archetype:alfresco-amp-archetype version:
1: 1.0
2: 1.0.1
3: 1.0.2
4: 1.1.0
5: 1.1.1
Choose a number: 5: 5
Define value for property 'groupId': : com.someco
Define value for property 'artifactId': : content-tutorial-repo
[INFO] Using property: version = 1.0-SNAPSHOT
[INFO] Using property: package = (not used)
[INFO] Using property: alfresco_target_amp_client_war = alfresco
[INFO] Using property: alfresco_target_amp_client_war_groupId = org.alfresco
[INFO] Using property: alfresco_target_amp_client_war_version = 4.2.e
[INFO] Using property: alfresco_target_groupId = org.alfresco
[INFO] Using property: alfresco_target_version = 4.2.e
Confirm properties configuration:
groupId: com.someco
artifactId: content-tutorial-repo
version: 1.0-SNAPSHOT
package: (not used)
alfresco_target_amp_client_war: alfresco
alfresco_target_amp_client_war_groupId: org.alfresco
alfresco_target_amp_client_war_version: 4.2.e
alfresco_target_groupId: org.alfresco
alfresco_target_version: 4.2.e
Y: Y



and the error within the maven-dir:



jan@kranich:~$ cd content-tutorial-repo/
jan@kranich:~/content-tutorial-repo$ mvn install
[INFO] Scanning for projects…
[INFO] ————————————————————————
[INFO] Building content-tutorial-repo AMP project
[INFO]    task-segment: [install]
[INFO] ————————————————————————
[INFO] [alfresco:set-version {execution: default-set-version}]
[INFO] Removed -SNAPSHOT suffix from version - 1.0
[INFO] Added timestamp to version - 1.0.1411111022
[INFO] [build-helper:add-test-resource {execution: add-env-test-properties}]
[INFO] [resources:resources {execution: default-resources}]
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory /home/jan/content-tutorial-repo/src/main/resources
[INFO] Copying 9 resources to ../content-tutorial-repo
[INFO] artifact org.jvnet.staxex:stax-ex: checking for updates from alfresco-public
[INFO] artifact org.jvnet.staxex:stax-ex: checking for updates from alfresco-public-snapshots
[INFO] artifact org.jvnet.staxex:stax-ex: checking for updates from jboss.public
[WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = '738169ccc9b91b7a5306e5783bc5fdc38b1fa881'; remote = '67f322c5b703204db28be907f94b642e00cb77b6' - RETRYING
[WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = '738169ccc9b91b7a5306e5783bc5fdc38b1fa881'; remote = '67f322c5b703204db28be907f94b642e00cb77b6' - IGNORING
[INFO] artifact org.jvnet.staxex:stax-ex: checking for updates from maven2-repository.dev.java.net
[INFO] artifact org.jvnet.staxex:stax-ex: checking for updates from central
[INFO] ————————————————————————
[ERROR] BUILD ERROR
[INFO] ————————————————————————
[INFO] Error building POM (may not be this project's POM).


Project ID: com.googlecode.concurrentlinkedhashmap:concurrentlinkedhashmap-lru:jar:1.2

Reason: Cannot find parent: org.sonatype.oss:oss-parent for project: com.googlecode.concurrentlinkedhashmap:concurrentlinkedhashmap-lru:jar:1.2 for project com.googlecode.concurrentlinkedhashmap:concurrentlinkedhashmap-lru:jar:1.2


Thanks!

Outcomes