AnsweredAssumed Answered

How to disable Solr Backup

Question asked by joe.l3 on Nov 14, 2014
Latest reply on Nov 24, 2014 by joe.l3

Hi all,

is there someone who has totally disabled the solr Backup scheduler in Alfresco Community?

I tried to set the "numberToKeep" properties to 0 for both archive and alfresco stores but it doesn't work. The cron trigger start anyway and a backup is performed…
I use Alfresco Community 4.2.f with the following configurations in the alfresco-global.properties:


### Start backup every 1 minute
solr.backup.alfresco.cronExpression=0 0/1 * * * ?
solr.backup.archive.cronExpression=0 0/1 * * * ?

### The backup directory
solr.backup.alfresco.remoteBackupLocation=${dir.root}/solrBackup/alfresco
solr.backup.archive.remoteBackupLocation=${dir.root}/solrBackup/archive

### Trying to disable backup using 0 retention
solr.backup.alfresco.numberToKeep=0
solr.backup.archive.numberToKeep=0



Actually, a (not recommended) workaround is to comment the two cron triggers bean's definition in webapps/alfresco/WEB-INF/classes/alfresco/subsystems/Search/solr/solr-backup-context.xml


<bean id="search.alfrescoCoreBackupTrigger" class="org.alfresco.util.CronTriggerBean">
<!– blablabla –>
</bean>
<!– blablabla –>
     <bean id="search.archiveCoreBackupTrigger" class="org.alfresco.util.CronTriggerBean">
<!– blablabla –>
</bean>



However this is not a good practice because I have to touch a  spring context of exploded alfresco  in the Tomcat webapps directory.
Is there any suggestion?

Outcomes