AnsweredAssumed Answered

Alfresco CE 5.0.c disponible, ¿para entornos productivos?

Question asked by angelborroy Moderator on Dec 5, 2014
Latest reply on Dec 10, 2014 by ualfresco
Estas últimas semanas muchos habéis estado preguntando sobre qué versión Community elegir para realizar una implantación en un entorno productivo.

En primer lugar me gustaría aclarar que Alfresco CE es tan fiable como Alfresco EE en lo relativo a la seguridad con la que se gestionan los documentos, de hecho el motor de repositorio que emplean es prácticamente el mismo. Sin embargo, la versión CE cuenta con algunas carencias funcionales (por ejemplo la consola web de administración o algunas integraciones con servicios de terceros) y técnicas (la versión CE no dispone de soporte para despliegue en alta disponibilidad) que pueden hacerla no recomendable para entornos críticos o con un gran volumen de documentos (> 300.000) o usuarios (> 3.000). Asimismo, la versión EE se licencia con un soporte completo que es proporcionado por técnicos de alto nivel que Alfresco pone a disposición de todos los clientes en régimen 24/7.

Por otro lado, la versión CE es válida para ser usada en entornos productivos aunque en ocasiones presenta algunos inconvenientes que deben ser solucionados por el equipo de implantación bien mediante la programación de parches de software o bien mediante omisión de determinados servicios.

En conclusión: puede implantarse Alfresco CE para su uso real, pero requiere más atención y cuidado que la versión EE para su mantenimiento.

En lo relativo a qué versión elegir. Como la mayoría de los productos, Alfresco libera versiones periódicamente y algunas presentan más problemas que otras. Por normal general, las primeras versiones (.a, .b) suelen ser poco recomendables ya que incluyen muchas funcionalidades nuevas que aún no han sido terminadas de pulir. Sin embargo, en ocasiones ocurre que una versión ".d" es menos utilizable que una versión ".c" por algún motivo técnico concreto. También hay que tener en cuenta que Alfresco no resuelve todas las incidencias de la rama CE, como sí ocurre en la rama EE que además incluye la entrega de parches de mantenimiento, sino que selecciona las más relevantes para ser incluidas en la siguiente liberación. Así que es posible que una incidencia que hayáis detectado y reportado simplemente no sea resuelta en la rama CE. Según mi criterio, entre las versiones más recomendables de los últimos años están la 4.2.c, la 4.2.f y la 5.0.c

La versión 5.0.c todavía está recién salida, así que no puede asegurarse su fiabilidad con tanta confianza como la versión 4.2.f o 4.2.c, pero en nuestras primeras pruebas está demostrando un comportamiento perfecto. Así que si alguien quiere implantar hoy una versión de Alfresco CE, le recomendaría a nivel personal que utilizase la 5.0.c

Espero que esta información os sirva de ayuda y os animo a que sigáis experimentando con esta plataforma.

También os recuerdo que disponéis de diferentes recursos para conocer más a fondo la comunidad del producto, tanto en la página oficial de Alfresco (http://wiki.alfresco.com/wiki/Main_Page) como en otros grupos ajenos a la organización (http://orderofthebee.org)

Outcomes