AnsweredAssumed Answered

Upgrade from 4.1.3 to 4.2.3

Question asked by sanket on Dec 11, 2014
Latest reply on Dec 15, 2014 by sanket
I am upgrading Alfresco 4.1.3 EE to Alfresco 4.2.3 EE.
After following the upgradation steps, and deploying my code to 4.2.3, when I start the server, I get the following exception :

org.springframework.beans.factory.CannotLoadBeanClassException: Cannot find class [org.alfresco.repo.workflow.activiti.AlfrescoBpmnParseListener] for bean with name 'activitiParseListener' defined in class path resource [alfresco/activiti-context.xml];

Has anybody come across such error while upgrading ?

Attaching log for reference.
I checked for this class (AlfrescoBpmnParseListener). Its not available in the SDK for 4.2.3. So is it replaced by some other class ? If yes, which one ?

Attachments

Outcomes