AnsweredAssumed Answered

Override JS

Question asked by denz on Jan 15, 2015
Latest reply on Jan 19, 2015 by denz
Hello,

une société a développé pour moi un script installé à l'aide d'un fichier amp.

Tout fonctionne mais pour parfaire à mon utilisation, j'ai overidé leur script (fichier HTML) en placant les fichiers à overrider dans "Entrepot > Dictionnaire de données > webscripts".

La aussi, ca fonctionne sauf que… impossible d'overider le fichier js.

dans l'override du webscript j'ai fait ainsi :

créé un fichier formulaire.get.html.ftl > l'override fonctionne

maintenant dans ce fichier html est appelé un fichier javascript que je voudrais overrider, mais impossible j'ai une erreur "A valid SecureContext was not provided in the RequestContext"

pour le surcharger j'ai créé un fichier au meme endroit qui s'appelle "formulaire.get.js"
quoi que je fasse dans ce fichier, meme si je mets alert("Hello"); il affiche cette erreur :'(

J'ai vu que c'était peut etre un probleme d'autorisation, mais mon formulaire en authenfication "none" car c'est un formulaire web "public"… alors comment faire pour surcharger mon fichier javascript ?

Merci d'avance

Outcomes