AnsweredAssumed Answered

EMLTransformer.java issue in Community 5.0.c

Question asked by drisschelouati on Mar 25, 2015
Latest reply on Mar 25, 2015 by drisschelouati
Hi,

I started using the email client integration for Alfresco community 5.0.c (iam using thunderbird) and noticed a major issue when dragging and dropping an email to the repository (EML file).

When switching to the preview, an email with some attachements can be up 50 to 150 pages of code shown, meaning that something is not working with the transformer.

This recent article is about this issue : https://loftux.com/en/blog/how-to-fix-email-transformation-and-indexing-bug-in-5.0

The kind of thing you get on an EML preview is like this:


——=_NextPart_000_046B_01D029C3.6802CD40
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: 8bit

Some email text
——=_NextPart_000_046B_01D029C3.6802CD40
Content-Type: application/ms-tnef;
name="winmail.dat"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="winmail.dat"

eJ8+IgMOAQaQCAAEAAAAAAABAAEAAQeQBgAIAAAA5AQAAAAAAADoAAEIgAcAGAAAAElQTS5NaWNy
b3NvZnQgTWFpbC5Ob3RlADEIAQgABQAEAAAAAAAAAAAAAQkABAACAAAAAAAAAAEDkAYA1BkAAF4A
AAALAAIAAQAAAAMAJgAAAAAACwApAAAAAAALACsAAAAAAAMALgAAAAAAQABIABLOPvy6KdABAgFM


and that could go very long on several dozens of pages, meaning for someone that manages a lot of emails everyday, incoming performance and indexing issues.(attachements are not currently handled because of the issue)

The fix proposed by this article is to delete some rows in the EMLTransformer.java to fix the issue:

if (charset != null)
{
mimeMessage.setHeader("Content-Type", "text/plain; charset=" + charset.name());
mimeMessage.setHeader("Content-Transfer-Encoding", "quoted-printable");


But to perform this fix, i suppose it implies to rebuild alfresco from source to apply the changes to the EMLTransformer.java file. So:

1- Is there any way to fix this issue in an already installed alfresco environnement? if yes, what could be the steps?

2- Or do we have to wait for the next alfresco release to solve this issue?

email drag and drop is really an interesting feature, it would be awesome to figure out a fix that doesnt imply rebuilding from source and reinstalling the environnement.

Thank you

Outcomes