AnsweredAssumed Answered

Document upload partly failes (document exists, but is not downloadable) due to mail rule

Question asked by progdevtom on Apr 7, 2015
We encountered a problem while setting up a mailing rule in our folder structure.
Situation is as follows (Alfresco enterprise 4.1.8)

MainProcesFolder
          ->subProcesFolder
                   ->Dossier1
                   ->Dossier2
                   ….
                   ->Dossier400
          ->subProcesFolder2
          ->subProcesFolder3
          ->subProcesFolder4
         
The process is an HR process, so only a specific GROUP has access to the "MainProcesFolder"
In the subProcesFolder lots of people, who have to deliver documents of their department,have access. They are delivered a direct link to this location.
These people have acces to certain DossierX folders.

Since we like to be updated on which Dossier is updated, we tried to set a mailing rule on the "subProcesFolder" and it's Dossiers. (I also tried a script to mail the details to the HR people involved, but the result are the same:)

When one of the departementpeople, who have access, uploads a document into a Dossier Folder, The upload starts and subsequently failes with the note:
for the mailing rule:
"4 kB (Mislukt: silently rolled back because it has been marked as rollback-only)"
for the mailing script:
"4 kB (Mislukt: Failed to execute script 'workspace://SpacesStore/20ec558f-241b-48c3-92ec-2a005e19b210': 030738983 Failed to send email to:X)"

The Results are:
- no mail is sent
- The document was uploaded, is actually present in alfresco: it has a noderef all properties, are set, however when you click download, you get redirected to a:
——————————————-
Web Script Status 404 - Not Found
404 Description:   Requested resource is not available.
Message:   03070111 Unable to locate content for node ref workspace://SpacesStore/2ec9cd6f-76c7-4868-b564-b42549f79a5c (property: {http://www.alfresco.org/model/content/1.0}content)
Exception:   org.springframework.extensions.webscripts.WebScriptException - 03070111 Unable to locate content for node ref workspace://SpacesStore/2ec9cd6f-76c7-4868-b564-b42549f79a5c (property: {http://www.alfresco.org/model/content/1.0}content)
————————————————-
So the rollback did not happen completely successfull.

in the logging you will find:
<blockcode>
get(shareUrl) failed on instance of org.alfresco.repo.template.TemplateNode
The problematic instruction:
———-
==> ${document.shareUrl} [on line 52, column 52 in workspace://SpacesStore/4e29a40b-a57c-4cc5-acd5-ab722ac03f37]
———-

Java backtrace for programmers:

</blockcode>
Does anyone have an idea how to set a mailing rule with these permission settings? that actually can work?
As far as I can see the problem is that the person uploading the file, does not have any permission on one of the sublevels.
Can the problem be that therefor the ${document.shareUrl} in the mail template isn't allowed?

Outcomes