AnsweredAssumed Answered

Problema para mostrar un Custom Action

Question asked by magarcia_sm on Apr 20, 2015
Latest reply on Apr 21, 2015 by magarcia_sm
Hola

  Estoy intentando crear una acción siguiendo el capítulo 4 del Alfresco Developer Guide. El código es exactamente el mismo que en la guía. Creo el AMP y lo instalo sin problemas en el .war de Alfresco y ejecuto Tomcamt sin ningún Error. Cuando voy a asignar una acción a un documento no me aparece dicha acción que he creado.
¿Alguna idea de cual puede ser el problema?
Aquí os dejo el código que he creado y una imagen de la estructura del proyecto.
Gracias.


someco-actions-context.xml

<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>

   <!– Logger Action Bean –>
   <bean id="set-web-flag" class="org.alfresco.test.executer.SetWebFlag" parent="action-executer">
      <property name="nodeService">
         <ref bean="nodeService" />
      </property>
      <property name="publicAction">
         <value>true</value>
      </property>
   </bean>

   <!– Load the Logger Action Messages –>
   <bean id="someco-action-messages" parent="actionResourceBundles">
      <property name="resourceBundles">
         <list>
            <value>alfresco.extension.test-actions</value>
         </list>
      </property>
   </bean>

</beans>


test-actions.properties

set-web-flag.title=Sets the SC Web Flag
set-web-flag.description=This will add the sc:webable aspect and set the isActive flag.


Attachments

Outcomes