AnsweredAssumed Answered

[SOLVED] Duplicate node index in Alfresco 5

Question asked by matthieulaborie on Apr 24, 2015
Hi,

I have  an Alfresco 5 community installation (5.0c or 5.0d both has issue) with custom AMP modules. When I create a file and then move that file from Repository to site or from site to site. It duplicate my node in solr 4. If I then search my file it will appear twice or more under search results. Running solr report I get:

Count of duplicate nodes in the index 100  which should be 0
First duplicate node id in the index 25973    

How I can find what is going wrong, how I can diagnose this kind of error?

Does anyone reproduce this issue under alfresco 5 community? Doing a full reindex fix it, but moving again docs make error appears.

Thanks for your help.
Regards

———

UPDATE: I've made a fresh install of Alfresco 5.0.d community without any custom AMPs and I can reproduce it easily:
 
Steps to reproduce:

- Create a sample site test, create a text file (I've named it duplicate)
- Move the file to repository root or other site
- Search for duplicate
- Notice the number of results (2)

See attach files
    

Waiting to be able to create a JIRA issue.


———

Solved in trunk by https://issues.alfresco.com/jira/browse/MNT-13767


Attachments

Outcomes