AnsweredAssumed Answered

Download of document using shared link and Internet ExplorerE

Question asked by jays on May 15, 2015
Latest reply on May 10, 2016 by fat_kid
Hello All

I am a complete newbie to Alfresco and need some assistance. I am not even sure if this is the right section of the forum to place this article in, but cannot see where else it goes.

I have created the site successfully, uploaded docs .. etc.

When I create a shared link to a doc and send it to an external person he clicks on the link and up comes the previewer with a download link. So far so good.
When he clicks on the download/download original menu option the following is experienced:
- Using Firefox on Mac/PC - NO PROBLEMS
- Using Safari on Mac/PC - NO PROBLEM
- Using Chrome on Mac/PC - NO PROBLEM
- Using Internet Explorer on PC - get the following errors:

*******************************************************************************************************************
Web Script Status 500 - Internal Error

The Web Script /alfresco/s/api/internal/shared/node/WDygyd97RLaq-zZSaIukYA/content/Lenovo Fusion Professional Datasheet.pdf has responded with a status of 500 - Internal Error.

500 Description: An error inside the HTTP server which prevented it from fulfilling the request.
 
Message: java.lang.NullPointerException
  
Server: Community v5.0.0 (d r99759-b2) schema 8,022
Time: 15-May-2015 13:23:39
  
Diagnostics: Inspect Web Script (org/alfresco/repository/quickshare/content-noauth.get)
*******************************************************************************************************************

When I click the link to inspect the error I get the following:

*******************************************************************************************************************
Web Script: org/alfresco/repository/quickshare/content-noauth.get
Generated from /alfresco/s/script/org/alfresco/repository/quickshare/content-noauth.get on 15-May-2015 13:24:41

Script Properties
Id: org/alfresco/repository/quickshare/content-noauth.get
Short Name: QuickShare - get some "shared" content
Description: If QuickShare exists, the content stream is retrieved for the specified document. 
Authentication: none
Transaction: none
Method: GET
URL Template: /api/internal/shared/node/content{property}/{shared_id}?a={attach?}
URL Template: /api/internal/shared/node/{shared_id}/content{property}?a={attach?}
Format Style: argument
Default Format: [undefined]
Negotiated Formats: [undefined]
Implementation: class org.alfresco.repo.web.scripts.quickshare.QuickShareContentGet
Extensions: [undefined]

Store: workspace://SpacesStore/app:company_home/app:dictionary/cm:extensionwebscripts

[No implementation files]

Store: workspace://SpacesStore/app:company_home/app:dictionary/cm:webscripts

[No implementation files]

Store: classpath:alfresco/templates/webscripts

File: org/alfresco/repository/quickshare/content-noauth.get.desc.xml 
<webscript>
  <shortname>QuickShare - get some "shared" content</shortname>
  <description>
  <![CDATA[
  If QuickShare exists, the content stream is retrieved for the specified document.
  ]]>
  </description>
  <url>/api/internal/shared/node/content{property}/{shared_id}?a={attach?}</url>
  <url>/api/internal/shared/node/{shared_id}/content{property}?a={attach?}</url>
  <format default="">argument</format>
  <authentication>none</authentication>
  <transaction allow="readonly"/>
  <lifecycle>internal</lifecycle>
</webscript>

Store: classpath:webscripts

[No implementation files]
*******************************************************************************************************************

Is there some configuration I have missed????

Could someone please assist me with curing this issue. I am sure I am not the first one to experience this, but searching the forum does not reveal it.

My server is Windows 2003r2-x64 and it has 32GB RAM.

Thanks and hope you can solve this for me.

J

Attachments

Outcomes