AnsweredAssumed Answered

Build Error with new SDK 2.1

Question asked by eswbitto on May 25, 2015
Latest reply on May 29, 2015 by eswbitto
I'm not sure what is going on here, but I've gone through Ole's video on setting up the 2.1 SDK. When I run the configuration this is the output that I get.



[INFO] Scanning for projects…
[INFO] Downloading: http://oss.sonatype.org/content/groups/public/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.pom
[INFO] Downloading: https://oss.sonatype.org/content/repositories/snapshots/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.pom
[INFO] Downloading: https://artifacts.alfresco.com/nexus/content/groups/public/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.pom
[INFO] Downloading: https://artifacts.alfresco.com/nexus/content/groups/public-snapshots/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.pom
[INFO] Downloading: http://repo.maven.apache.org/maven2/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.pom
[INFO] Downloading: http://clojars.org/repo/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.pom
[INFO] Downloaded: http://clojars.org/repo/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.pom (4 KB at 10.4 KB/sec)
[INFO] Downloading: http://oss.sonatype.org/content/groups/public/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.jar
[INFO] Downloading: https://oss.sonatype.org/content/repositories/snapshots/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.jar
[INFO] Downloading: https://artifacts.alfresco.com/nexus/content/groups/public/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.jar
[INFO] Downloading: https://artifacts.alfresco.com/nexus/content/groups/public-snapshots/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.jar
[INFO] Downloading: http://repo.maven.apache.org/maven2/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.jar
[INFO] Downloading: http://clojars.org/repo/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.jar
[INFO] Downloaded: http://clojars.org/repo/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.jar (13 KB at 62.8 KB/sec)
[INFO]
[INFO] Using the builder org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder with a thread count of 1
[INFO]                                                                        
[INFO] ————————————————————————
[INFO] Building my-alfresco-amp Repository AMP project 1.0-SNAPSHOT
[INFO] ————————————————————————
[INFO]
[INFO] — alfresco-maven-plugin:2.1.0:set-version (default-set-version) @ my-alfresco-amp —
[WARNING] Error injecting: org.alfresco.maven.plugin.VersionMojo
java.lang.TypeNotPresentException: Type org.alfresco.maven.plugin.VersionMojo not present
   at org.eclipse.sisu.space.URLClassSpace.loadClass(URLClassSpace.java:115)
   at org.eclipse.sisu.space.NamedClass.load(NamedClass.java:46)
   at org.eclipse.sisu.space.AbstractDeferredClass.get(AbstractDeferredClass.java:48)
   at com.google.inject.internal.ProviderInternalFactory.provision(ProviderInternalFactory.java:86)
   at com.google.inject.internal.InternalFactoryToInitializableAdapter.provision(InternalFactoryToInitializableAdapter.java:55)
   at com.google.inject.internal.ProviderInternalFactory$1.call(ProviderInternalFactory.java:70)
   at com.google.inject.internal.ProvisionListenerStackCallback$Provision.provision(ProvisionListenerStackCallback.java:100)
   at org.eclipse.sisu.plexus.PlexusLifecycleManager.onProvision(PlexusLifecycleManager.java:133)
   at com.google.inject.internal.ProvisionListenerStackCallback$Provision.provision(ProvisionListenerStackCallback.java:109)
   at com.google.inject.internal.ProvisionListenerStackCallback.provision(ProvisionListenerStackCallback.java:55)
   at com.google.inject.internal.ProviderInternalFactory.circularGet(ProviderInternalFactory.java:68)
   at com.google.inject.internal.InternalFactoryToInitializableAdapter.get(InternalFactoryToInitializableAdapter.java:47)
   at com.google.inject.internal.InjectorImpl$2$1.call(InjectorImpl.java:997)
   at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1047)
   at com.google.inject.internal.InjectorImpl$2.get(InjectorImpl.java:993)
   at com.google.inject.Scopes$1$1.get(Scopes.java:59)
   at org.eclipse.sisu.inject.LazyBeanEntry.getValue(LazyBeanEntry.java:82)
   at org.eclipse.sisu.plexus.LazyPlexusBean.getValue(LazyPlexusBean.java:51)
   at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:260)
   at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:252)
   at org.apache.maven.plugin.internal.DefaultMavenPluginManager.getConfiguredMojo(DefaultMavenPluginManager.java:462)
   at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:120)
   at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208)
   at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
   at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
   at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:108)
   at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:76)
   at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
   at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:116)
   at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:361)
   at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:155)
   at org.apache.maven.cli.MavenCli.execute(MavenCli.java:584)
   at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:213)
   at org.apache.maven.cli.MavenCli.main(MavenCli.java:157)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:606)
   at org.springsource.loaded.ri.ReflectiveInterceptor.jlrMethodInvoke(ReflectiveInterceptor.java:1270)
   at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
   at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
   at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
   at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
Caused by: java.lang.UnsupportedClassVersionError: org/alfresco/maven/plugin/VersionMojo : Unsupported major.minor version 52.0
   at java.lang.ClassLoader.defineClass1(Native Method)
   at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
   at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
   at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
   at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
   at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
   at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
   at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(ClassRealm.java:389)
   at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:42)
   at org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:259)
   at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:235)
   at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:227)
   at org.eclipse.sisu.space.URLClassSpace.loadClass(URLClassSpace.java:107)
   … 42 more
[INFO] ————————————————————————
[INFO] BUILD FAILURE
[INFO] ————————————————————————
[INFO] Total time: 19.256 s
[INFO] Finished at: 2015-05-25T13:23:44-05:00
[INFO] Final Memory: 29M/989M
[INFO] ————————————————————————
[ERROR] Failed to execute goal org.alfresco.maven.plugin:alfresco-maven-plugin:2.1.0:set-version (default-set-version) on project my-alfresco-amp: Execution default-set-version of goal org.alfresco.maven.plugin:alfresco-maven-plugin:2.1.0:set-version failed: Unable to load the mojo 'set-version' in the plugin 'org.alfresco.maven.plugin:alfresco-maven-plugin:2.1.0' due to an API incompatibility: org.codehaus.plexus.component.repository.exception.ComponentLookupException: org/alfresco/maven/plugin/VersionMojo : Unsupported major.minor version 52.0
[ERROR] —————————————————–
[ERROR] realm =    plugin>org.alfresco.maven.plugin:alfresco-maven-plugin:2.1.0
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
[ERROR] urls[0] = file:/root/.m2/repository/org/alfresco/maven/plugin/alfresco-maven-plugin/2.1.0/alfresco-maven-plugin-2.1.0.jar
[ERROR] urls[1] = file:/root/.m2/repository/org/sonatype/sisu/sisu-inject-bean/2.3.0/sisu-inject-bean-2.3.0.jar
[ERROR] urls[2] = file:/root/.m2/repository/org/sonatype/sisu/sisu-guice/3.1.0/sisu-guice-3.1.0-no_aop.jar
[ERROR] urls[3] = file:/root/.m2/repository/org/sonatype/sisu/sisu-guava/0.9.9/sisu-guava-0.9.9.jar
[ERROR] urls[4] = file:/root/.m2/repository/org/apache/maven/maven-archiver/2.5/maven-archiver-2.5.jar
[ERROR] urls[5] = file:/root/.m2/repository/org/codehaus/plexus/plexus-utils/3.0/plexus-utils-3.0.jar
[ERROR] urls[6] = file:/root/.m2/repository/org/codehaus/plexus/plexus-interpolation/1.15/plexus-interpolation-1.15.jar
[ERROR] urls[7] = file:/root/.m2/repository/org/codehaus/plexus/plexus-archiver/2.3/plexus-archiver-2.3.jar
[ERROR] urls[8] = file:/root/.m2/repository/junit/junit/3.8.1/junit-3.8.1.jar
[ERROR] urls[9] = file:/root/.m2/repository/org/codehaus/plexus/plexus-io/2.0.6/plexus-io-2.0.6.jar
[ERROR] urls[10] = file:/root/.m2/repository/org/sonatype/aether/aether-util/1.13.1/aether-util-1.13.1.jar
[ERROR] urls[11] = file:/root/.m2/repository/org/codehaus/plexus/plexus-component-annotations/1.5.5/plexus-component-annotations-1.5.5.jar
[ERROR] urls[12] = file:/root/.m2/repository/org/sonatype/plexus/plexus-sec-dispatcher/1.3/plexus-sec-dispatcher-1.3.jar
[ERROR] urls[13] = file:/root/.m2/repository/org/sonatype/plexus/plexus-cipher/1.4/plexus-cipher-1.4.jar
[ERROR] urls[14] = file:/root/.m2/repository/org/apache/httpcomponents/httpclient/4.3/httpclient-4.3.jar
[ERROR] urls[15] = file:/root/.m2/repository/org/apache/httpcomponents/httpcore/4.3/httpcore-4.3.jar
[ERROR] urls[16] = file:/root/.m2/repository/commons-logging/commons-logging/1.1.3/commons-logging-1.1.3.jar
[ERROR] urls[17] = file:/root/.m2/repository/commons-codec/commons-codec/1.6/commons-codec-1.6.jar
[ERROR] urls[18] = file:/root/.m2/repository/commons-net/commons-net/3.3/commons-net-3.3.jar
[ERROR] urls[19] = file:/root/.m2/repository/commons-io/commons-io/2.1/commons-io-2.1.jar
[ERROR] urls[20] = file:/root/.m2/repository/org/alfresco/alfresco-mmt/5.0.d/alfresco-mmt-5.0.d.jar
[ERROR] urls[21] = file:/root/.m2/repository/org/alfrescolabs/alfresco-technical-validation/org.alfrescolabs.alfresco-technical-validation/0.4.0/org.alfrescolabs.alfresco-technical-validation-0.4.0.jar
[ERROR] urls[22] = file:/root/.m2/repository/org/clojure/clojure/1.6.0/clojure-1.6.0.jar
[ERROR] urls[23] = file:/root/.m2/repository/org/clojure/tools.cli/0.3.1/tools.cli-0.3.1.jar
[ERROR] urls[24] = file:/root/.m2/repository/org/clojure/tools.logging/0.3.0/tools.logging-0.3.0.jar
[ERROR] urls[25] = file:/root/.m2/repository/clojurewerkz/neocons/3.0.0/neocons-3.0.0.jar
[ERROR] urls[26] = file:/root/.m2/repository/cheshire/cheshire/5.3.1/cheshire-5.3.1.jar
[ERROR] urls[27] = file:/root/.m2/repository/com/fasterxml/jackson/core/jackson-core/2.3.1/jackson-core-2.3.1.jar
[ERROR] urls[28] = file:/root/.m2/repository/com/fasterxml/jackson/dataformat/jackson-dataformat-smile/2.3.1/jackson-dataformat-smile-2.3.1.jar
[ERROR] urls[29] = file:/root/.m2/repository/tigris/tigris/0.1.1/tigris-0.1.1.jar
[ERROR] urls[30] = file:/root/.m2/repository/clj-http/clj-http/0.9.1/clj-http-0.9.1.jar
[ERROR] urls[31] = file:/root/.m2/repository/org/apache/httpcomponents/httpmime/4.3.2/httpmime-4.3.2.jar
[ERROR] urls[32] = file:/root/.m2/repository/slingshot/slingshot/0.10.3/slingshot-0.10.3.jar
[ERROR] urls[33] = file:/root/.m2/repository/crouton/crouton/0.1.1/crouton-0.1.1.jar
[ERROR] urls[34] = file:/root/.m2/repository/org/jsoup/jsoup/1.7.1/jsoup-1.7.1.jar
[ERROR] urls[35] = file:/root/.m2/repository/org/clojure/tools.reader/0.8.3/tools.reader-0.8.3.jar
[ERROR] urls[36] = file:/root/.m2/repository/potemkin/potemkin/0.3.4/potemkin-0.3.4.jar
[ERROR] urls[37] = file:/root/.m2/repository/clj-tuple/clj-tuple/0.1.2/clj-tuple-0.1.2.jar
[ERROR] urls[38] = file:/root/.m2/repository/riddley/riddley/0.1.6/riddley-0.1.6.jar
[ERROR] urls[39] = file:/root/.m2/repository/clojurewerkz/support/0.20.0/support-0.20.0.jar
[ERROR] urls[40] = file:/root/.m2/repository/com/google/guava/guava/14.0.1/guava-14.0.1.jar
[ERROR] urls[41] = file:/root/.m2/repository/clojurewerkz/urly/2.0.0-alpha5/urly-2.0.0-alpha5.jar
[ERROR] urls[42] = file:/root/.m2/repository/ch/qos/logback/logback-classic/1.1.2/logback-classic-1.1.2.jar
[ERROR] urls[43] = file:/root/.m2/repository/ch/qos/logback/logback-core/1.1.2/logback-core-1.1.2.jar
[ERROR] urls[44] = file:/root/.m2/repository/org/slf4j/slf4j-api/1.7.6/slf4j-api-1.7.6.jar
[ERROR] urls[45] = file:/root/.m2/repository/me/raynes/conch/0.7.0/conch-0.7.0.jar
[ERROR] urls[46] = file:/root/.m2/repository/org/flatland/useful/0.10.6/useful-0.10.6.jar
[ERROR] urls[47] = file:/root/.m2/repository/org/clojure/tools.macro/0.1.1/tools.macro-0.1.1.jar
[ERROR] urls[48] = file:/root/.m2/repository/jansi-clj/jansi-clj/0.1.0/jansi-clj-0.1.0.jar
[ERROR] urls[49] = file:/root/.m2/repository/org/fusesource/jansi/jansi/1.11/jansi-1.11.jar
[ERROR] urls[50] = file:/root/.m2/repository/io/aviso/pretty/0.1.12/pretty-0.1.12.jar
[ERROR] urls[51] = file:/root/.m2/repository/org/clojars/pmonks/depends/0.3.0/depends-0.3.0.jar
[ERROR] urls[52] = file:/root/.m2/repository/org/clojure/data.json/0.2.4/data.json-0.2.4.jar
[ERROR] urls[53] = file:/root/.m2/repository/org/ow2/asm/asm/5.0.3/asm-5.0.3.jar
[ERROR] urls[54] = file:/root/.m2/repository/net/java/truevfs/truevfs-kernel-impl/0.10.6/truevfs-kernel-impl-0.10.6.jar
[ERROR] urls[55] = file:/root/.m2/repository/net/java/truevfs/truevfs-kernel-spec/0.10.6/truevfs-kernel-spec-0.10.6.jar
[ERROR] urls[56] = file:/root/.m2/repository/net/java/truecommons/truecommons-cio/2.3.4/truecommons-cio-2.3.4.jar
[ERROR] urls[57] = file:/root/.m2/repository/net/java/truecommons/truecommons-io/2.3.4/truecommons-io-2.3.4.jar
[ERROR] urls[58] = file:/root/.m2/repository/net/java/truecommons/truecommons-services/2.3.4/truecommons-services-2.3.4.jar
[ERROR] urls[59] = file:/root/.m2/repository/net/java/truecommons/truecommons-logging/2.3.4/truecommons-logging-2.3.4.jar
[ERROR] urls[60] = file:/root/.m2/repository/javax/inject/javax.inject/1/javax.inject-1.jar
[ERROR] urls[61] = file:/root/.m2/repository/org/scala-lang/scala-library/2.10.3/scala-library-2.10.3.jar
[ERROR] urls[62] = file:/root/.m2/repository/net/java/truevfs/truevfs-access/0.10.6/truevfs-access-0.10.6.jar
[ERROR] urls[63] = file:/root/.m2/repository/net/java/truevfs/truevfs-driver-file/0.10.6/truevfs-driver-file-0.10.6.jar
[ERROR] urls[64] = file:/root/.m2/repository/net/java/truevfs/truevfs-driver-zip/0.10.6/truevfs-driver-zip-0.10.6.jar
[ERROR] urls[65] = file:/root/.m2/repository/net/java/truevfs/truevfs-comp-ibm437/0.10.6/truevfs-comp-ibm437-0.10.6.jar
[ERROR] urls[66] = file:/root/.m2/repository/net/java/truevfs/truevfs-comp-zipdriver/0.10.6/truevfs-comp-zipdriver-0.10.6.jar
[ERROR] urls[67] = file:/root/.m2/repository/net/java/truevfs/truevfs-comp-zip/0.10.6/truevfs-comp-zip-0.10.6.jar
[ERROR] urls[68] = file:/root/.m2/repository/org/apache/commons/commons-compress/1.7/commons-compress-1.7.jar
[ERROR] urls[69] = file:/root/.m2/repository/org/bouncycastle/bcprov-jdk16/1.46/bcprov-jdk16-1.46.jar
[ERROR] urls[70] = file:/root/.m2/repository/net/java/truevfs/truevfs-driver-jar/0.10.6/truevfs-driver-jar-0.10.6.jar
[ERROR] urls[71] = file:/root/.m2/repository/net/java/truecommons/truecommons-key-disable/2.3.4/truecommons-key-disable-2.3.4.jar
[ERROR] urls[72] = file:/root/.m2/repository/net/java/truecommons/truecommons-key-spec/2.3.4/truecommons-key-spec-2.3.4.jar
[ERROR] urls[73] = file:/root/.m2/repository/net/java/truecommons/truecommons-shed/2.3.4/truecommons-shed-2.3.4.jar
[ERROR] urls[74] = file:/root/.m2/repository/org/clojars/pmonks/multigrep/0.2.0/multigrep-0.2.0.jar
[ERROR] urls[75] = file:/root/.m2/repository/org/clojars/pmonks/bookmark-writer/0.1.0/bookmark-writer-0.1.0.jar
[ERROR] urls[76] = file:/root/.m2/repository/org/docx4j/docx4j/3.0.1/docx4j-3.0.1.jar
[ERROR] urls[77] = file:/root/.m2/repository/org/plutext/jaxb-svg11/1.0.2/jaxb-svg11-1.0.2.jar
[ERROR] urls[78] = file:/root/.m2/repository/org/plutext/jaxb-xslfo/1.0.1/jaxb-xslfo-1.0.1.jar
[ERROR] urls[79] = file:/root/.m2/repository/org/plutext/jaxb-xmldsig-core/1.0.0/jaxb-xmldsig-core-1.0.0.jar
[ERROR] urls[80] = file:/root/.m2/repository/commons-lang/commons-lang/2.4/commons-lang-2.4.jar
[ERROR] urls[81] = file:/root/.m2/repository/org/apache/xmlgraphics/xmlgraphics-commons/1.5/xmlgraphics-commons-1.5.jar
[ERROR] urls[82] = file:/root/.m2/repository/org/apache/xmlgraphics/fop/1.1/fop-1.1.jar
[ERROR] urls[83] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-svg-dom/1.7/batik-svg-dom-1.7.jar
[ERROR] urls[84] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-anim/1.7/batik-anim-1.7.jar
[ERROR] urls[85] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-css/1.7/batik-css-1.7.jar
[ERROR] urls[86] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-dom/1.7/batik-dom-1.7.jar
[ERROR] urls[87] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-parser/1.7/batik-parser-1.7.jar
[ERROR] urls[88] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-util/1.7/batik-util-1.7.jar
[ERROR] urls[89] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-bridge/1.7/batik-bridge-1.7.jar
[ERROR] urls[90] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-script/1.7/batik-script-1.7.jar
[ERROR] urls[91] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-js/1.7/batik-js-1.7.jar
[ERROR] urls[92] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-xml/1.7/batik-xml-1.7.jar
[ERROR] urls[93] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-awt-util/1.7/batik-awt-util-1.7.jar
[ERROR] urls[94] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-gvt/1.7/batik-gvt-1.7.jar
[ERROR] urls[95] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-transcoder/1.7/batik-transcoder-1.7.jar
[ERROR] urls[96] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-svggen/1.7/batik-svggen-1.7.jar
[ERROR] urls[97] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-extension/1.7/batik-extension-1.7.jar
[ERROR] urls[98] = file:/root/.m2/repository/org/apache/xmlgraphics/batik-ext/1.7/batik-ext-1.7.jar
[ERROR] urls[99] = file:/root/.m2/repository/org/apache/avalon/framework/avalon-framework-api/4.3.1/avalon-framework-api-4.3.1.jar
[ERROR] urls[100] = file:/root/.m2/repository/org/apache/avalon/framework/avalon-framework-impl/4.3.1/avalon-framework-impl-4.3.1.jar
[ERROR] urls[101] = file:/root/.m2/repository/xalan/xalan/2.7.1/xalan-2.7.1.jar
[ERROR] urls[102] = file:/root/.m2/repository/xalan/serializer/2.7.1/serializer-2.7.1.jar
[ERROR] urls[103] = file:/root/.m2/repository/net/arnx/wmf2svg/0.9.0/wmf2svg-0.9.0.jar
[ERROR] urls[104] = file:/root/.m2/repository/org/apache/poi/poi-scratchpad/3.8/poi-scratchpad-3.8.jar
[ERROR] urls[105] = file:/root/.m2/repository/org/apache/poi/poi/3.8/poi-3.8.jar
[ERROR] urls[106] = file:/root/.m2/repository/org/antlr/antlr-runtime/3.3/antlr-runtime-3.3.jar
[ERROR] urls[107] = file:/root/.m2/repository/org/antlr/stringtemplate/3.2.1/stringtemplate-3.2.1.jar
[ERROR] urls[108] = file:/root/.m2/repository/antlr/antlr/2.7.7/antlr-2.7.7.jar
[ERROR] urls[109] = file:/root/.m2/repository/org/clojars/pmonks/spinner/0.2.0/spinner-0.2.0.jar
[ERROR] Number of foreign imports: 1
[ERROR] import: Entry[import  from realm ClassRealm[project>jbitto:my-alfresco-amp:1.0-SNAPSHOT, parent: ClassRealm[maven.api, parent: null]]]
[ERROR]
[ERROR] —————————————————–
[ERROR] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginContainerException

Outcomes