AnsweredAssumed Answered

Versioning not working

Question asked by simonsimonson on Jul 23, 2015
Latest reply on Jul 31, 2015 by ajmas
I have recently come across a problem. I have created a new content type extending dl:dataListItem and noticed that versioning is not working whenever I try to save it. I create the object by invoking createDocument(updatePops, null, VersioningState.Major).
The problem is that when i try to update the doc, the version does not change and stays at 1.0. I have a different content type created way back also extending dl:dataListItem and versioning for those docs is working (only for the old docs/not the new). Otherwise I have not explicitly enabled versioning anywhere (having in mind that versioning worked for the older datalist child object).

I was wondering if I missed something in the dev process or is there a problem with alfresco.

P.S. I have tried to delete the content models in alf_data, tried changing the version from the CmisExtension API in java, also in the share and with CmisWorkbench.

Outcomes