AnsweredAssumed Answered

sdk and records management

Question asked by davidraines on Sep 1, 2015
Latest reply on Sep 1, 2015 by davidraines
I'm trying to add Records Management support to an Alfresco project created from the SDK 2.0.0 all-in-one archetype, and I get the error "Bean property 'useLocalCaches' is not writable".  This was discussed before, but solution isn't working for me.  I'm stuck.

When I run:
    
$mvn integration-test -Prun

my application loads correctly, but when I run
    
$mvn integration-test -Prun,rm

it fails.

And it works, but when I add "rm" to the list of profiles, I get the error "Context initialization failed"
caused by:
Caused by: org.springframework.beans.NotWritablePropertyException: Invalid property 'useLocalCaches' of bean class [org.alfresco.ibatis.HierarchicalSqlSessionFactoryBean]: Bean property 'useLocalCaches' is not writable or has an invalid setter method.


I see that this was discussed <a href="https://forums.alfresco.com/forum/developer-discussions/development-environment/records-management-plugin-03192014-1453
">before</a>

The solution was to run the command:
$mvn clean install -Prm


I can run that command without error.  But that command doesn't actually launch my server.  When I try to <b>run</b> the All-in-one project I've created:
$mvn install -Prun,rm
   OR
$mvn integration-test -Prun,rm


The error occurs, and Alfresco doesn't launch correctly.
Am I missing something?

Thanks,
David

Outcomes