AnsweredAssumed Answered

Can not connect to a repository

Question asked by n3k on Sep 2, 2015
Latest reply on Sep 3, 2015 by n3k
Hello,
I am very new in Alfresco and CMIS.
II tried the firs example of creating a session to a repository.
I created a maven project and I have just a main java class in which I try to create the session.
The problem is that when I try to connect to any repository I got a connection failure.
I have tried
- http://localhost:8181/opencmis/atom/
- http://localhost:8080/alfresco/cmisatom
Even in the case of public Alfresco repository http://cmis.alfresco.com/cmisatom it failes again.
The only case that instead of connection error I got an Unauthorized error is the case of  http://localhost:8080/alfresco/api/-default-/cmis/versions/1.1/atom

You will find my code below:
                // default factory implementation
      SessionFactory factory = SessionFactoryImpl.newInstance();
      Map<String, String> parameter = new HashMap<String, String>();

      // user credentials
      parameter.put(SessionParameter.USER, "admin");
      parameter.put(SessionParameter.PASSWORD, "admin");

      // connection settings
      parameter.put(SessionParameter.ATOMPUB_URL, "http://cmis.alfresco.com/cmisatom");
      parameter.put(SessionParameter.BINDING_TYPE, BindingType.ATOMPUB.value());
      parameter.put(SessionParameter.REPOSITORY_ID, "97b8bac9-52dd-4667-9d0d-70d0032fddb0");
      
      // create session
      Session session = factory.createSession(parameter);

Maybe my question is too trivial but I am really confused.
Thank you in advance
Kind regards,
N3k

Outcomes