AnsweredAssumed Answered

Missing Libraries on Ubuntu

Question asked by dspencer on Sep 13, 2015
Latest reply on Sep 14, 2015 by dspencer
I am having a bit of an odd problem with my Alfresco install. Previously I had a working instance of Alfresco Community 5.0d running on Ubuntu. It was installed some months ago originally 5.0a and updated to c and then d on their release. Recently I noticed that some of the previews for some office documents were not being displayed and after troubleshooting that for a while I was unable to find the issue. Finally, I took a zip of my alfresco folder from the server, did a fresh install of Ubuntu, downloaded the Alfresco binaries and tried to install again. Since then I keep getting the following error whenever I try to install;

:/opt$ ./alfresco-community-5.0.d-installer-linux-x64.bin
Some or all of the libraries necessary to support LibreOffice were not found on your system: fontconfig libSM libICE libXrender libXext libcups
You are strongly advised to abort this installation and install them first using your package manager.
For more information, please refer to http://docs.alfresco.com/4.2/topic/com.alfresco.enterprise.doc/concepts/install-lolibfiles.html

Do you want to continue with the installation? [y/N]:


I have tried to use nightly versions, early releases, as well as the 5.0d version but so far, the same thing happens when I start the install. I have tried multiple versions of Ubuntu (14.04, 12.10, 13.(something, I forget which)) all giving the same error. I followed the link in the message and ran the apt-get command displayed on the help page but that did not seem to make a difference. I would think this is a fairly frequent issue given the steps to reproduce it for me but searches online have yielded only old errors which seem to be resolved by installing the listed libraries.

Any assistance at all is greatly appreciated.

Outcomes