AnsweredAssumed Answered

solr4 version conflict

Question asked by sharifu on Oct 1, 2015
Latest reply on Oct 29, 2015 by sscbrian
I am upgrading to alfresco 5.0.b from 4.2.f and I have notice the following and would liek to know how to sove it.



org.apache.solr.common.SolrException: version conflict for _DEFAULT_!8000000000000300!800000000017d21d expected=1513025908295860224 actual=1513025908313686016
   at org.apache.solr.update.processor.DistributedUpdateProcessor.versionAdd(DistributedUpdateProcessor.java:976)
   at org.apache.solr.update.processor.DistributedUpdateProcessor.processAdd(DistributedUpdateProcessor.java:693)
   at org.alfresco.solr.SolrInformationServer.updateContentToIndexAndCache(SolrInformationServer.java:2138)
   at org.alfresco.solr.tracker.ContentTracker$ContentIndexWorkerRunnable.doWork(ContentTracker.java:117)
   at org.alfresco.solr.tracker.AbstractWorkerRunnable.run(AbstractWorkerRunnable.java:40)
   at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
   at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)

Outcomes