AnsweredAssumed Answered

Alfresco 5.0.d -- Moodle [2.9]

Question asked by gonial on Oct 21, 2015
Latest reply on Oct 21, 2015 by gonial
Buenos días a todos.

Estoy terminando mi proyecto desarrollado en Java y utilizando Alfresco como gestor documental.

Por ahora todo iba bien hasta el punto que necesitaba conectar mi versión de Alfresco con moodle 2.9.

Hasta este momento las conexiones entre mi aplicación web y Alfresco lo hacia a través de OpenCMIS ya que la versión 5.0.d no permite usar el protocolo SOAP y eso no era un requisito imprescindible.

Ahora, una vez intento conectarme con moodle y estudiando un poco su formación, me encuentro con esto dentro la web de moodle https://docs.moodle.org/29/en/Alfresco_repository .

<strong>The Alfresco repository enables users to link to or copy files from Alfresco into Moodle.

Note: The Alfresco plugin does not work with Alfresco 5.0.c or later. It is intended eventually to remove this repository from standard Moodle and include it in the Plugins directory.</strong>

Pues es ahora donde necesito un poco de consejo, de que si quizás debería instalar la versión 5.0.a en mi máquina y probar si esta versión me permite usar tanto openCmis para la conexión AplicacionWeb-Alfresco y usar a la vez los WebServices para la parte de Alfresco-Moodle2.9. O si quizás podría seguir usando mi actual versión de Alfresco 5.0.d utilizando alguna extensión disponible para tal caso (yo por lo menos no he encontrado nada válido para la versión 5.0.d).

Eso es todo por ahora, pero de todas maneras os dejaré la forma en la que configuro Moodle para conectarme con Alfresco, no vaya a ser que este cometiendo aquí el problema.




Outcomes