AnsweredAssumed Answered

Installing Alfresco Community edition 5.0a on JBoss Application Server 7.1.1

Question asked by rohit21886 on Jan 15, 2016
Hello,

We are trying to deploy Alfresco Community edition 5.0a on JBoss Application Server 7.1.1. Can someone please let us know what is the correct way to deploy the Alfresco's war files, taken from the location "/alfresco-community-5.0.a/web-server" on to the JBoss.

System details are as follows:
OS: Ubuntu 14.04
Java:  OpenJDK Runtime Environment (IcedTea 2.6.3) (7u91-2.6.3-0ubuntu0.14.04.1)

We tried keeping the WAR files (wix. alfresco.war and share.war) under deployments folder in JBOss (/jboss_as/jboss-as-7.1.1.Final/standalone/deployments) and started the server. We got below messages:

17:03:08,865 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) Class Path entry xercesImpl.jar in "/content/alfresco.war/WEB-INF/lib/xalan-2.7.0.jar"  does not point to a valid jar for a Class-Path reference.
17:03:08,866 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) Class Path entry xml-apis.jar in "/content/alfresco.war/WEB-INF/lib/xalan-2.7.0.jar"  does not point to a valid jar for a Class-Path reference.
17:03:08,869 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) Class Path entry serializer.jar in "/content/alfresco.war/WEB-INF/lib/xalan-2.7.0.jar"  does not point to a valid jar for a Class-Path reference.
17:03:08,877 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) Class Path entry jaxws-api.jar in "/content/alfresco.war/WEB-INF/lib/jaxws-rt-2.1.7.jar"  does not point to a valid jar for a Class-Path reference.
17:03:08,882 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) Class Path entry jsr181-api.jar in "/content/alfresco.war/WEB-INF/lib/jaxws-rt-2.1.7.jar"  does not point to a valid jar for a Class-Path reference..
.
.
.
.
17:03:14,004 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC00001: Failed to start service jboss.deployment.unit."alfresco.war".STRUCTURE: org.jboss.msc.service.StartException in service jboss.deployment.unit."alfresco.war".STRUCTURE: Failed to process phase STRUCTURE of deployment "alfresco.war"
   at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
   at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
   at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
   at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_91]
   at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_91]
   at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_91]
Caused by: java.lang.IllegalArgumentException: Given parent is not an ancestor of this virtual file
   at org.jboss.vfs.VirtualFile.getPathNameRelativeTo(VirtualFile.java:116)
   at org.jboss.vfs.VirtualFile.getPathNameRelativeTo(VirtualFile.java:122)
   at org.jboss.vfs.VirtualFile.getPathNameRelativeTo(VirtualFile.java:110)
   at org.jboss.as.server.deployment.module.ManifestClassPathProcessor.createAdditionalModule(ManifestClassPathProcessor.java:193) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
   at org.jboss.as.server.deployment.module.ManifestClassPathProcessor.handlingExistingClassPathEntry(ManifestClassPathProcessor.java:185) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
   at org.jboss.as.server.deployment.module.ManifestClassPathProcessor.deploy(ManifestClassPathProcessor.java:162) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
   at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]
   … 5 more
.
.
.

Also attached is the server log file.

Any help will be greatly appreciated.

Thanks !!

Attachments

Outcomes