AnsweredAssumed Answered

Document preview using Aikau not displaying correctly

Question asked by jonno70 on Sep 24, 2016

Hi

 

I have created a number of Aikau pages and widgets using Eclipse and SDK 2.2 and I am having a problem with the document preview.

To simply things...

  • I have created a new Eclipse "share" project and created a the home page from from Dave Draper's excellent tutorial - from the later chapter that has the document preview.  This works perfectly when I run it from eclipse.
  • I then installed the amp into a clean install of Community (build 201605 - Alfresco 5.1.g & share 5.1.f)
  • The content from the swsdp site display correctly in Share.
  • When i use "http://localhost:8080/share/page/dp/ws/home" and navigate to a document in the site the preview displays the first page of the document, without the "toolbar" -  navigation, download zoom, etc.  they very briefly display (blink and you miss it) and then disappear and the page takes up the whole window.  This happens with all the content the the site - pdf, doc, xls, jpg

 

I am guessing I am missing a setting in a configuration file somewhere - I am just not sure where.

 

Any help would be greatly appreciated.

 

Thanks, Jon

 

Update 1..

 

I should have done this earlier - with logging turned on.

I get the following.

Y >> Loading PDF file from http://localhost:8080/share/proxy/alfresco/api/node/workspace/SpacesStore/1…64a4e/content/Project%20Contract.pdf?c=force&noCache=1474763626048&a=false
67bad83….js:228

c >> Error:PdfJs failed to display: TypeError: PDFJS.getDocument is not a function

 

Update 2

 

After much trial and error...

 

By accident I came across

The release version of aikau is 1.0.63 (aikau-1.0.63.jar)

The version in my eclipse is 1.0.39.5 (aikau-1.0.39.5.jar)

 

I copied target/amp-war/WEB-INF/lib/aikau-1.0.39.5.jar over tomcat/webapps/share/WEB-INF/lib/aikau-1.0.63.jar

and everything now works....

I also tried to go back the other way - and that "broke" the eclipse version.

Outcomes