AnsweredAssumed Answered

Alfresco is running without Share Services

Question asked by michael_s on Sep 29, 2016
Latest reply on Jul 20, 2018 by malcolmc

Hi,  I hope someone can help.

 

I have activated passthru authentication, but since doing so, I am getting the message "Alfresco is running without Share Services. See your System Administrator for more details."

 

I have made the same change to two servers, one running Alfresco One trial 5.1.1 and one running Alfresco Community 5.1.0 (r127059-b7).  Both are displaying the same issue.

 

The authentication chain is:

authentication.chain=alfinst:alfrescoNtlm,passthru1:passthru,ad1:ldap-ad,ad2:ldap-ad

 

ntlm.authentication.sso.enabled=true

ldap.authentication.active=false

 

Contents of passthru-authentication-context.properties

passthru.authentication.useLocalServer=False

passthru.authentication.domain=

passthru.authentication.servers=AU\\server22.ourdomain.com,server22.ourdomain.com

passthru.authentication.authenticateCIFS=false

passthru.authentication.connectTimeout=5000

passthru.authentication.offlineCheckInterval=300

passthru.authentication.protocolOrder=TCPIP,NetBIOS

passthru.authentication.defaultAdministratorUserNames=jsmith,admin

 

The LDAP synchronisation is working great.  I have two because I am getting two different groups of people.

Users can sign on with no problem.  admin can sign on using the alfrescoNtlm.

 

If I remove passthru, the error goes away.

 

I am using http port 8080 and all other settings are out of the box.

 

In alfresco-global.properties

 

The line share.host is fully qualified instead of 127.0.0.1

share.host=server101.ourdomain.com

 

Any help or pointers appreciated.

Outcomes