AnsweredAssumed Answered

Share: Upload new Version => InvalidNodeRefException: Node does not exist

Question asked by mrks.js1 on Oct 28, 2016
Latest reply on Oct 29, 2016 by mrks.js1

Hi

 

We have 1 corrupt document in our 5.0.d instance.

 

The issue can be reproduced like that:

  • User tries to upload new version in share (of this particular pdf)
  • => upload fails, every time.

 

log output:

Caused by: org.alfresco.service.cmr.repository.InvalidNodeRefException: Node does not exist: workspace://SpacesStore/a16e49b5-a516-4c1a-b85f-140990595ff9 (status:Status[id=839815changeTxnId=db0d014e-01f3-461a-ae3b-abb822dd651e, dbTxnId=399375, deleted=true])

 

which makes sense - since workspace://SpacesStore/a16e49b5-a516-4c1a-b85f-140990595ff9 does not exist!

 

I tried to figure out if something might be wrong with the index but index is looking good. (tried retry, fix, purge error nodes, reindex txns of error nodes)

 

This particular pdf document has ~150 versions. I can't revert older versions, can't copy or move the document. 

That is the only difference I can see right now. Updating versions of other documents is working fine.

Can't find anything fishy about the node other than that it is broken. Preview works btw. :/

Attachments

Outcomes