AnsweredAssumed Answered

activity-modeler web app throwing error (activiti-5.0.beta2)

Question asked by sdhaliwal on Oct 29, 2010
Latest reply on Nov 2, 2010 by sdhaliwal
Hi,
  I just downloaded activiti-5.0.beta2 version of the Activiti and tried to run the demo.setup ant task. The activity-modeler web app seems to be throwing the following error.
SEVERE: Null component Catalina:type=JspMonitor,name=jsp,WebModule=//localhost/activiti-modeler,J2EEApplication=none,J2EEServer=none
Oct 29, 2010 11:15:21 AM org.apache.catalina.startup.HostConfig deployWAR
SEVERE: Error deploying web application archive activiti-modeler.war
java.lang.UnsupportedClassVersionError: (com/signavio/platform/listeners/EntryPoint) bad major version at offset=6 (unable to load class com.signavio.platform.listeners.EntryPoint)
   at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2737)
   at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1124)
   at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1612)
   at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1491)
   at org.apache.catalina.startup.WebAnnotationSet.loadClassAnnotation(WebAnnotationSet.java:145)
   at org.apache.catalina.startup.WebAnnotationSet.loadApplicationListenerAnnotations(WebAnnotationSet.java:73)
   at org.apache.catalina.startup.WebAnnotationSet.loadApplicationAnnotations(WebAnnotationSet.java:56)
   at org.apache.catalina.startup.ContextConfig.applicationAnnotationsConfig(ContextConfig.java:297)
   at org.apache.catalina.startup.ContextConfig.start(ContextConfig.java:1078)
   at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:261)
   at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
   at org.apache.catalina.core.StandardContext.start(StandardContext.java:4540)
   at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
   at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
   at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:546)
   at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:905)
   at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:740)
   at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:500)
   at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1277)
   at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:321)
   at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
   at org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
   at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:445)
   at org.apache.catalina.core.StandardService.start(StandardService.java:519)
   at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
   at org.apache.catalina.startup.Catalina.start(Catalina.java:581)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:615)
   at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
   at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)

It seems that this class has been compiled using jdk 1.6.x as the version of the class is 50. I tried to run it using both jre 1.5x as well as jre 1.6.x and it threw the same error. Can you indicate if there is a problem with my local setup or there is an issue with the downloaded package.

Thanks

Outcomes