AnsweredAssumed Answered

Rename JavaDelegation & JavaDelegationDelegate

Question asked by falko.menge on Nov 2, 2010
Latest reply on Nov 3, 2010 by tombaeyens
According to the Gang of Four and multiple other sources the interface JavaDelegation should be called JavaDelegate whereas the class JavaDelegationDelegate should be called JavaDelegator.

As this is a very important interface, which most Activiti users will have to implement and talk about, I'd suggest to be very clear in terminology and rename these two entities to match the delegation design pattern before the GA release.