AnsweredAssumed Answered

Exception deploying activiti-webapp-init in Activiti-5.0.rc1

Question asked by gerry.fisher on Nov 4, 2010
Latest reply on Nov 11, 2010 by gerry.fisher
Hello,

OS: Windows XP
Tomcat version: 6.0.29
Oracle version: 9i
JDBC Driver version: 11.2.0.1.0 (ojdbc5.jar)

Here's a snippet of the console dump:


04-Nov-2010 15:17:44 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory activiti-webapp-init
04-Nov-2010 15:17:45 oracle.jdbc.driver.OracleDriver registerMBeans
SEVERE: Error while registering Oracle JDBC Diagnosability MBean.
javax.management.MalformedObjectNameException: Invalid character '
' in value part of property
        at javax.management.ObjectName.construct(ObjectName.java:602)
        at javax.management.ObjectName.<init>(ObjectName.java:1403)
        at oracle.jdbc.driver.OracleDriver.registerMBeans(OracleDriver.java:303)
        at oracle.jdbc.driver.OracleDriver$1.run(OracleDriver.java:213)
        at java.security.AccessController.doPrivileged(Native Method)
        at oracle.jdbc.driver.OracleDriver.<clinit>(OracleDriver.java:209)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:247)
        at org.apache.ibatis.datasource.unpooled.UnpooledDataSource.initializeDriver(UnpooledDataSource.java:173)
        at org.apache.ibatis.datasource.unpooled.UnpooledDataSource.getConnection(UnpooledDataSource.java:57)
        at org.apache.ibatis.datasource.pooled.PooledDataSource.popConnection(PooledDataSource.java:349)
        at org.apache.ibatis.datasource.pooled.PooledDataSource.getConnection(PooledDataSource.java:55)
        at org.apache.ibatis.session.defaults.DefaultSqlSessionFactory.openSessionFromDataSource(DefaultSqlSessionFactory.java:72)
        at org.apache.ibatis.session.defaults.DefaultSqlSessionFactory.openSession(DefaultSqlSessionFactory.java:40)
        at org.activiti.engine.impl.db.DbSqlSessionFactory.dbSchemaCheckVersion(DbSqlSessionFactory.java:229)
        at org.activiti.engine.impl.ProcessEngineImpl.performSchemaOperationsCreate(ProcessEngineImpl.java:102)
        at org.activiti.engine.impl.ProcessEngineImpl$1.execute(ProcessEngineImpl.java:70)
        at org.activiti.engine.impl.interceptor.CommandExecutorImpl.execute(CommandExecutorImpl.java:22)
        at org.activiti.engine.impl.interceptor.CommandContextInterceptor.execute(CommandContextInterceptor.java:36)
        at org.activiti.engine.impl.interceptor.LogInterceptor.execute(LogInterceptor.java:33)
        at org.activiti.engine.impl.ProcessEngineImpl.<init>(ProcessEngineImpl.java:68)
        at org.activiti.engine.impl.cfg.ProcessEngineConfiguration.buildProcessEngine(ProcessEngineConfiguration.java:302)
        at org.activiti.engine.ProcessEngineBuilder.buildProcessEngine(ProcessEngineBuilder.java:272)
        at org.activiti.engine.ProcessEngines.buildProcessEngine(ProcessEngines.java:150)
        at org.activiti.engine.ProcessEngines.initProcessEnginFromResource(ProcessEngines.java:124)
        at org.activiti.engine.ProcessEngines.init(ProcessEngines.java:83)
        at org.activiti.impl.servlet.listener.ProcessEnginesServletContextListener.contextInitialized(ProcessEnginesServletContextListener.java:30)
        at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4135)

I'm not sure which property contains the rogue ' character. It is nothing in the build.oracle.properties file. Could this be some Oracle SQL dialect issue?

Regards,

Gerry

Outcomes