AnsweredAssumed Answered

Eclipse plugin installation issue

Question asked by olivier.nouguier on Dec 3, 2010
Latest reply on Jul 18, 2011 by trademak
Hi,
Look like the atctiviti bpm designer has an "old" dep on org.eclipse.wst.sse.ui [1.2.0.v201006030742] which conflict with last version available (1.2.2 …).
Is there a fix planned, a workaround ?
Thanks.

(Downgrading is not an option).

Cannot complete the install because of a conflicting dependency.
  Software being installed: Activiti Eclipse BPMN 2.0 Designer 0.6.0 (org.activiti.designer.feature.feature.group 0.6.0)
  Software currently installed: Eclipse XML Editors and Tools SDK 3.2.2.v201008170029-7A558DXHQWiYiMFK1Zr7Mncwx_7Y (org.eclipse.wst.xml_sdk.feature.feature.group 3.2.2.v201008170029-7A558DXHQWiYiMFK1Zr7Mncwx_7Y)
  Only one of the following can be installed at once:
    Structured Source Editor 1.2.2.v201008232126 (org.eclipse.wst.sse.ui 1.2.2.v201008232126)
    Structured Source Editor 1.2.0.v201006030742 (org.eclipse.wst.sse.ui 1.2.0.v201006030742)
    Structured Source Editor 1.2.1.v201007141733 (org.eclipse.wst.sse.ui 1.2.1.v201007141733)
  Cannot satisfy dependency:
    From: Activiti Eclipse BPMN 2.0 Designer 0.6.0 (org.activiti.designer.feature.feature.group 0.6.0)
    To: org.eclipse.wst.sse.ui [1.2.0.v201006030742]
  Cannot satisfy dependency:
    From: Eclipse XML Editors and Tools SDK 3.2.2.v201008170029-7A558DXHQWiYiMFK1Zr7Mncwx_7Y (org.eclipse.wst.xml_sdk.feature.feature.group 3.2.2.v201008170029-7A558DXHQWiYiMFK1Zr7Mncwx_7Y)
    To: org.eclipse.wst.xml_ui.feature.feature.group [3.2.2.v201008170029-7H7AFUQDxumQGOpBqffOY2f1qxDZ]
  Cannot satisfy dependency:
    From: Eclipse XML Editors and Tools 3.2.2.v201008170029-7H7AFUQDxumQGOpBqffOY2f1qxDZ (org.eclipse.wst.xml_ui.feature.feature.group 3.2.2.v201008170029-7H7AFUQDxumQGOpBqffOY2f1qxDZ)
    To: org.eclipse.wst.sse.ui [1.2.2.v201008232126]

Outcomes