AnsweredAssumed Answered

Exception while initializing process engine Can't debug

Question asked by skougiou on Feb 15, 2011
Latest reply on Nov 18, 2014 by jbarrez
Hello,

I am trying to initialize the activiti engine through a jsp scriptlet and I keep receiving this error from the console :

INFO: Exception while initializing process engine :org/springframework/beans/factory/support/BeanDefinitionRegistry

when I try to debug I manage to dig until the following call inside the file : ProcessEngines.class :

private static  ProcessEngine buildProcessEngine(URL resource) {
    InputStream inputStream = null;
    try {
      inputStream = resource.openStream();
      ProcessEngineConfiguration processEngineConfiguration = ProcessEngineConfiguration.createProcessEngineConfigurationFromInputStream(inputStream);
      return processEngineConfiguration.buildProcessEngine();
     
    } catch (IOException e) {
      throw new ActivitiException("couldn't open resource stream: "+e.getMessage(), e);
    } finally {
      IoUtil.closeSilently(inputStream);
    }
  }

The problem is that I can't step into   .createProcessEngineConfigurationFromInputStream(inputStream);
to find out what is going on, because when hitting "step into" the debugger jumps to the finally section.
( I have already tried to enable breakpoints inside the function createProcessEngineConfigurationFromInputStream  ) it just keeps moving on to the finally section.

Apparently another exception is being fired…other than IOException. I can't see clearly what the exception is because this call : createProcessEngineConfigurationFromInputStream   does not throws any exception

Thank you for your time! :)

Outcomes