AnsweredAssumed Answered

Issues Running BPMN 2.0 HelloWorld on MySQL

Question asked by zicongwang on Feb 22, 2011
Latest reply on Feb 24, 2011 by jbarrez
Hi all,
  I installed the Eclipse designer and run a hello world example it can run smoothly. And I configure the database from h2 to mysql the example can run smoothly and no error occurs but I can not find any record in the mysql database when I run the process in the eclipse.The steps I perform is
1.Complete the hello world BPMN with eclipse designer
2.generate the unit test example with ecplise designer
3.run the unit test

The hello world can run correctly,when I deploy the hello world according to activiti expro I can find the process record in the mysql ,but I can not find any record in mysql database, when I run the process in the eclipse , How can I configure eclipse so that I can store the process detail in the mysql database? I change the activiti.cfg.xml to the following and put it in the src/test/java but it does not work

<?xml version="1.0" encoding="UTF-8"?>

<beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://www.springframework.org/schema/beans   http://www.springframework.org/schema/beans/spring-beans.xsd">

  <bean id="processEngineConfiguration" class="org.activiti.engine.impl.cfg.StandaloneProcessEngineConfiguration">
 
    <!– Database configurations –>
    <property name="databaseType" value="mysql" />
    <property name="jdbcUrl" value="jdbc:mysql://localhost:3306/activiti?autoReconnect=true" />
    <property name="jdbcDriver" value="com.mysql.jdbc.Driver" />
    <property name="jdbcUsername" value="activiti" />
    <property name="jdbcPassword" value="activiti" />
   
  </bean>

</beans>

Outcomes