AnsweredAssumed Answered

how to use MyBatis 3.0.4?

Question asked by rengeng1986 on Mar 28, 2011
Latest reply on May 23, 2011 by frederikheremans1
My project use MyBatis3.0.4, and mybaitis-spring
i known issue is , problem is none if don't use integration of mybatis-spring.
somebody can help me?
and Activiti5.?? will use MyBatis33.0.4 version or latest?

Following is error msg

org.apache.ibatis.exceptions.PersistenceException: 
### Error querying database.  Cause: java.lang.IllegalArgumentException: Mapped Statements collection does not contain value for selectProperty
### The error may exist in org/activiti/db/ibatis/variable.mapping.xml
### Cause: java.lang.IllegalArgumentException: Mapped Statements collection does not contain value for selectProperty
   at org.apache.ibatis.exceptions.ExceptionFactory.wrapException(ExceptionFactory.java:8)
   at org.apache.ibatis.session.defaults.DefaultSqlSession.selectList(DefaultSqlSession.java:77)
   at org.apache.ibatis.session.defaults.DefaultSqlSession.selectList(DefaultSqlSession.java:69)
   at org.apache.ibatis.session.defaults.DefaultSqlSession.selectOne(DefaultSqlSession.java:40)
   at org.activiti.engine.impl.db.DbSqlSession.selectById(DbSqlSession.java:195)
   at org.activiti.engine.impl.db.DbSqlSession.dbSchemaUpdate(DbSqlSession.java:601)
   at org.activiti.engine.impl.db.DbSqlSession.performSchemaOperationsProcessEngineBuild(DbSqlSession.java:854)

Outcomes