AnsweredAssumed Answered

Activiti demo.start with MSSQL

Question asked by al_lv on Apr 8, 2011
Hallo,

there are same problems with demo.start and mssql server
#####

     [java] SCHWERWIEGEND: problem during schema create, statement 'create unique index ACT_UNIQ_RU_BUS_KEY on ACT_RU_EXECUTION (PROC_DEF_ID_, BUSINESS_KEY_) where BUSINESS_KEY_ is not null

This create statement should be without  "where BUSINESS_KEY_ is not null".

These files should be changed:
org\activiti\db\create\activiti.mssql.create.engine.sql
org\activiti\db\create\activiti.mssql.create.history.sql

in these libs:
activiti-engine-5.4-sources.jar
activiti-engine-5.4.jar


####
    
[java] INFO: performing create on cycle with resource org/activiti/db/create/activiti.mssql.create.cycle.sql
     [java] 08.04.2011 15:26:52 org.activiti.engine.impl.db.DbSqlSession execute SchemaResource
     [java] SCHWERWIEGEND: problem during schema create, statement 'create table
ACT_CY_CONFIG (
     [java] ID_ nvarchar(255),
     [java] GROUP_ nvarchar(255),
     [java] KEY_ nvarchar(255),
     [java] VALUE_[b] clob[/b],
     [java] primary key (ID_)
     [java] )
     [java] java.sql.SQLException: Column or parameter #4: Cannot find data type[b] clob[/b].

it doesn't work with clob.
I tried it with varbinary(6500)!

So:
insert  into  ACT_CY_CONFIG values ('1', 
                           'processSolutionTemplates',
                           'default',
                           CONVERT(varbinary(6500),'<processSolutionTemplate>
                              <vFolder type="Management" name="Management" connectorId="Workspace" referencedNodeId="/" />
                              <vFolder type="Processes" name="Processes" connectorId="Activiti" referencedNodeId="/root-directory" />
                              <vFolder type="Requirements" name="Requirements" connectorId="Workspace" referencedNodeId="/" />
                              <vFolder type="Implementation" name="Implementation" connectorId="Workspace" referencedNodeId="/" />
                           </processSolutionTemplate>',0));

I'm not shure it is a right way. It works on my computer.
could you correct it in the next release please?

Thanks

Alexej

Outcomes