AnsweredAssumed Answered

Develop web application with activiti engine

Question asked by simonetogno on Apr 11, 2011
Latest reply on Apr 22, 2011 by simonetogno
Hi all

I'm trying to develop e web application that use activiti engine but I have encountered this problem:

I can't install in the same eclipse instance the activiti designer and the web tools platform.
It return this error.

Cannot complete the install because of a conflicting dependency.
  Software being installed: JST Web UI 3.2.3.v201101262333-7F77FJ_C25TkfyypjhqQuxNYsMrJ (org.eclipse.jst.web_ui.feature.feature.group 3.2.3.v201101262333-7F77FJ_C25TkfyypjhqQuxNYsMrJ)
  Software currently installed: Activiti Eclipse BPMN 2.0 Designer 5.4.0 (org.activiti.designer.feature.feature.group 5.4.0)
  Only one of the following can be installed at once:
    WST XML User Documentation 3.2.101.v201102161624-50FXNAkF7B77RBgFFBF (org.eclipse.wst.xml_userdoc.feature.feature.jar 3.2.101.v201102161624-50FXNAkF7B77RBgFFBF)
    WST XML User Documentation 3.2.100.v201005241420-50FXNAkF7B77RBgFFBF (org.eclipse.wst.xml_userdoc.feature.feature.jar 3.2.100.v201005241420-50FXNAkF7B77RBgFFBF)
  Cannot satisfy dependency:
    From: Activiti Eclipse BPMN 2.0 Designer 5.4.0 (org.activiti.designer.feature.feature.group 5.4.0)
    To: org.eclipse.wst.xml_ui.feature.feature.group [3.2.0.v201005241510-7H7AFUIDxumQGOb7ocjUR2Pvz-28]
  Cannot satisfy dependency:
    From: JST Web UI 3.2.3.v201101262333-7F77FJ_C25TkfyypjhqQuxNYsMrJ (org.eclipse.jst.web_ui.feature.feature.group 3.2.3.v201101262333-7F77FJ_C25TkfyypjhqQuxNYsMrJ)
    To: org.eclipse.wst.ws_ui.feature.feature.group [3.2.3.v201102160541-7I78FZIEtEoO2d7AsK6jSNqC-8jj]
  Cannot satisfy dependency:
    From: WST Web Services UI 3.2.3.v201102160541-7I78FZIEtEoO2d7AsK6jSNqC-8jj (org.eclipse.wst.ws_ui.feature.feature.group 3.2.3.v201102160541-7I78FZIEtEoO2d7AsK6jSNqC-8jj)
    To: org.eclipse.wst.xml_ui.feature.feature.group [3.2.3.v201102160550-7H7AFUWDxumQJOi9ghcTb5YgkwEZ]
  Cannot satisfy dependency:
    From: Eclipse XML Editors and Tools 3.2.0.v201005241510-7H7AFUIDxumQGOb7ocjUR2Pvz-28 (org.eclipse.wst.xml_ui.feature.feature.group 3.2.0.v201005241510-7H7AFUIDxumQGOb7ocjUR2Pvz-28)
    To: org.eclipse.wst.xml_userdoc.feature.feature.group [3.2.100.v201005241420-50FXNAkF7B77RBgFFBF]
  Cannot satisfy dependency:
    From: Eclipse XML Editors and Tools 3.2.3.v201102160550-7H7AFUWDxumQJOi9ghcTb5YgkwEZ (org.eclipse.wst.xml_ui.feature.feature.group 3.2.3.v201102160550-7H7AFUWDxumQJOi9ghcTb5YgkwEZ)
    To: org.eclipse.wst.xml_userdoc.feature.feature.group [3.2.101.v201102161624-50FXNAkF7B77RBgFFBF]
  Cannot satisfy dependency:
    From: WST XML User Documentation 3.2.100.v201005241420-50FXNAkF7B77RBgFFBF (org.eclipse.wst.xml_userdoc.feature.feature.group 3.2.100.v201005241420-50FXNAkF7B77RBgFFBF)
    To: org.eclipse.wst.xml_userdoc.feature.feature.jar [3.2.100.v201005241420-50FXNAkF7B77RBgFFBF]
  Cannot satisfy dependency:
    From: WST XML User Documentation 3.2.101.v201102161624-50FXNAkF7B77RBgFFBF (org.eclipse.wst.xml_userdoc.feature.feature.group 3.2.101.v201102161624-50FXNAkF7B77RBgFFBF)
    To: org.eclipse.wst.xml_userdoc.feature.feature.jar [3.2.101.v201102161624-50FXNAkF7B77RBgFFBF]



This error came when i try to install WTP on eclipse instance that have already install activiti designer plugin.

Can someone help me?

Regards

Simone

Outcomes