AnsweredAssumed Answered

Reference problem while extending activiti Designer

Question asked by simonetogno on May 11, 2011
Latest reply on Oct 26, 2011 by trademak
Hi all,

This is my problem:

I'm trying to extend the palette of activiti designer. I have followed the user guide but when I launch the command mvn eclipse:eclipse occur some error.
I've tried to extend the palet with te same example reported on the guide, thaken the pom.xml file from activiti source, updated the version ov designer reference (5.5), but it doesn't run well.
I think that one problem is the repository of extension file
http://maven.alfresco.com/nexus/content/repositories/activiti/

In thir repository the latest version is 0.7.0 (some version ago)

This is my pom.xml file

<?xml version="1.0" encoding="UTF-8"?>
<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd" xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <modelVersion>4.0.0</modelVersion>
   <groupId>MoneyTask</groupId>
   <artifactId>MoneyTask</artifactId>
   <packaging>jar</packaging>
   <name>Acme Corporation Money Task</name>
   <version>1.0.0</version>
   
   <dependencies>
      <dependency>
         <groupId>org.activiti.designer</groupId>
         <artifactId>org.activiti.designer.integration</artifactId>
         <version>5.5</version>
         <scope>compile</scope>
         <optional>false</optional>
      </dependency>
   </dependencies>
   <repositories>
        <repository>
            <id>Activiti</id>
            <url>http://maven.alfresco.com/nexus/content/repositories/activiti/</url>
         </repository>
   </repositories>
   <build>
   <plugins>
         <plugin>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
               <source>1.5</source>
               <target>1.5</target>
               <showDeprecation>true</showDeprecation>
               <showWarnings>true</showWarnings>
               <optimize>true</optimize>
            </configuration>
         </plugin>
         <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-jar-plugin</artifactId>
            <version>2.3.1</version>
            <configuration>
               <archive>
                  <index>true</index>
                  <manifest>
                     <addClasspath>false</addClasspath>
                     <addDefaultImplementationEntries>true</addDefaultImplementationEntries>
                  </manifest>
                  <manifestEntries>
                     <ActivitiDesigner-Extension-Name>Acme Money</ActivitiDesigner-Extension-Name>
                  </manifestEntries>
               </archive>
            </configuration>
         </plugin>
      </plugins>
    </build>
</project>

I hope that someone can help me.
Regards
Simone

Outcomes