AnsweredAssumed Answered

JAR file uses dos file separator rather than Linux file sepa

Question asked by ct1 on Sep 27, 2011
Latest reply on Sep 28, 2011 by ronald.van.kuijk
When I invoke the "Create deployment artifacts" in Eclipse, a deployment directory is created in my project.  Inside the deployment directory are a .bar file and a .jar file.  When I copy the .jar file to the activiti-5.7\apps\apache-tomcat-6.032\webapps\activiti-explorer\WEB-INF\lib, restart the demo project and execute the process, I get a ClassDefNotFound exception for one of the classes in the .jar file.  I noticed that the file separator character in the .jar file is "\", not "/".  I extracted the files from the .jar file and manually jarred them again.  This caused the Linux file separator to be used and I no longer got the ClassDefNotFound exception.  I also tried using the Eclipse "Export" to a Jar file; that worked too.

If the .jar file created by the "Create deployment artifacts" is not meant to be used, it might be less confusing to just remove it at the end of the "Create deployment artifacts" processing rather than leave something that will not work just sitting around begging to be used.

Thank you.

Outcomes