AnsweredAssumed Answered

Build error after importing sources from svn 5.9

Question asked by mhw on Nov 3, 2011
Latest reply on Nov 7, 2011 by mhw
Hi,

I am evaluating the sources because in the future i want to contribute, too. With 5.8 everything was fine. But with the 5.9 I get build errors:
03.11.11 13:37:15 MEZ: [ERROR] Error in manifest for org.activiti:activiti-engine:jar:5.9-SNAPSHOT : The default package '.' is not permitted by the Import-Package syntax. 
This can be caused by compile errors in Eclipse because Eclipse creates
valid class files regardless of compile errors.
The following package(s) import from the default package [org.activiti.engine.impl.ant, org.activiti.engine.impl.bpmn.behavior, org.activiti.engine.impl.cfg, org.activiti.engine.impl.db, org.activiti.engine.impl.interceptor, org.activiti.engine.impl.mail, org.activiti.engine.impl.persistence, org.activiti.engine.impl.rules, org.activiti.engine.impl.test, org.activiti.engine.impl.variable, org.activiti.engine.test]
03.11.11 13:37:15 MEZ: [ERROR] Error(s) found in manifest configuration
03.11.11 13:37:15 MEZ: Build errors for activiti-engine; org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.felix:maven-bundle-plugin:2.1.0:manifest (bundle-manifest) on project activiti-engine: Error(s) found in manifest configuration
I have done the steps explained here:
http://docs.codehaus.org/display/ACT/Developers+Guide#DevelopersGuide-Buildingadistributionfromthesource

I have no clue what that means. Can somebody please give me a tip?

Best Regards,
Michael

Outcomes