AnsweredAssumed Answered

Java 5 compatible?

Question asked by solutions on Nov 16, 2011
I can run Activiti Demo on JDK 1.6 fine, but NOT on JDK 1.5.

There is an exception when run on JDK 1.5:

[/WEB-INF/applicationContext.xml]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersion
Error: Bad version number in .class f
ile (unable to load class org.apache.commons.dbcp.BasicDataSource)
        at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveReference(BeanDefinitionValueResolver.java:328)
        at org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveValueIfNecessary(BeanDefinitionValueResolver.java:106)


Anything wrong with my environment settings?
Thanks.

Outcomes