AnsweredAssumed Answered

demo.start script stuck

Question asked by littlechameleon on Nov 27, 2011
Latest reply on Dec 4, 2011 by littlechameleon
PROBLEM UPDATED, JUMP TO POST #3 PLEASE

Hello Community!

I'm just getting started with Activiti as I saw many different implementations of it, I thought I'd give it a try.

Here's my setup:

PC: Core i5 650 (with Intel grahics), 4Gb RAM, Intel SSD X-25M

OS: OpenSUSE 12.1 (latest ditribution) x86_64

Software: ant 1.8.2-26.1, tomcat 6 + 7, eclipse IDE 3.4 –> all from official OSS repro noarch

I see that my version of eclipse ist not 3.6 as recommended.

When I fire up a terminal and launch the 'ant demo.start' script, it gest stuck after a few lines. The following is all that it does:

Buildfile: /home/username/bin/activiti-5.8/setup/build.xml

demo.install:

internal.cfg.create:
     [copy] Copying 1 file to /home/username/bin/activiti-5.8/setup/build/activiti-cfg
      [zip] Building zip: /home/username/bin/activiti-5.8/setup/build/activiti-cfg.jar
     [echo] copying configuration to ../workspace/activiti-engine-examples/src/main/config
    [unzip] Expanding: /home/username/bin/activiti-5.8/setup/build/activiti-cfg.jar into /home/daniel/bin/activiti-5.8/workspace/activiti-engine-examples/src/main/config

internal.classpath.libs:

internal.taskdef.launch:

h2.start:
     [echo] starting H2 database…
   [launch] launching cmd '/home/username/bin/activiti-5.8/apps/h2/h2.start.sh ' in dir '/home/daniel/bin/activiti-5.8/apps/h2'
   [launch] waiting for launch completion msg 'TCP server running on'…
   [launch]   Exception in thread "main" org.h2.jdbc.JdbcSQLException: Exception opening port "H2 TCP Server (tcp://192.168.1.234:9092)" (port may be in use), cause: "timeout" [90061-132]
   [launch]      at org.h2.message.DbException.getJdbcSQLException(DbException.java:316)
   [launch]      at org.h2.message.DbException.get(DbException.java:167)
   [launch]      at org.h2.tools.Server.start(Server.java:344)
   [launch]      at org.h2.tools.Server.runTool(Server.java:216)
   [launch]      at org.h2.tools.Server.main(Server.java:106)

Can someone help and tell why it's not getting any further? I tried that script with both USER and ROOT priviledge, same behavior…

Outcomes