AnsweredAssumed Answered

Adhoc process bpmn20.xml generation failure

Question asked by alexbt on Mar 4, 2012
Latest reply on Mar 5, 2012 by trademak
Hi guys,
I followed your suggestions (see my previous question at http://forums.activiti.org/en/viewtopic.php?f=6&t=3286) and everything worked correctly with Activiti 5.7.
After upgrading to 5.9 all my generated adhoc process definitions stopped to be correctly deployed.
Here is an example .bpmn20.xml file that I fail to deploy to the engine:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ns4:definitions xmlns:dc="http://www.omg.org/spec/DD/20100524/DC" xmlns:ns4="http://www.omg.org/spec/BPMN/20100524/MODEL" xmlns:di="http://www.omg.org/spec/DD/20100524/DI" xmlns:ns5="http://www.signavio.com" xmlns:ns6="http://activiti.org/bpmn" xmlns:bpmndi="http://www.omg.org/spec/BPMN/20100524/DI" targetNamespace="adhoc">
  <ns4:process isExecutable="false" name="One Script Task Workflow" id="adhoc_One_Script_Task_Workflow">
    <ns4:documentation id="adhoc_One_Script_Task_Workflow_documentation">Simple workflow definition containing one script task</ns4:documentation>
    <ns4:startEvent ns6:initiator="initiator" id="theStart"/>
    <ns4:sequenceFlow sourceRef="theStart" targetRef="task_1" id="flow_1"/>
    <ns4:scriptTask ns6:resultVariableName="myVar" scriptFormat="juel" name="Execute script" id="task_1">
      <ns4:script>#{echo}</ns4:script>
    </ns4:scriptTask>
    <ns4:endEvent id="theEnd"/>
    <ns4:sequenceFlow sourceRef="task_1" targetRef="theEnd" id="flow_2"/>
  </ns4:process>
  <bpmndi:BPMNDiagram id="One_Script_Task_Workflow_diagram">
    <bpmndi:BPMNPlane bpmnElement="adhoc_One_Script_Task_Workflow" id="One_Script_Task_Workflow_plane">
      <bpmndi:BPMNShape bpmnElement="theStart" id="theStart_shape">
        <dc:Bounds x="0.0" y="45.0" width="20.0" height="20.0"/>
      </bpmndi:BPMNShape>
      <bpmndi:BPMNEdge bpmnElement="flow_1" id="flow_1_edge">
        <di:waypoint x="20.0" y="55.0"/>
        <di:waypoint x="70.0" y="55.0"/>
      </bpmndi:BPMNEdge>
      <bpmndi:BPMNShape bpmnElement="task_1" id="task_1_shape">
        <dc:Bounds x="70.0" y="25.0" width="130.0" height="60.0"/>
      </bpmndi:BPMNShape>
      <bpmndi:BPMNEdge bpmnElement="flow_2" id="flow_2_edge">
        <di:waypoint x="200.0" y="55.0"/>
        <di:waypoint x="250.0" y="55.0"/>
      </bpmndi:BPMNEdge>
      <bpmndi:BPMNShape bpmnElement="theEnd" id="theEnd_shape">
        <dc:Bounds x="250.0" y="45.0" width="20.0" height="20.0"/>
      </bpmndi:BPMNShape>
    </bpmndi:BPMNPlane>
  </bpmndi:BPMNDiagram>
</ns4:definitions>

And here is the exception i get:

org.activiti.engine.ActivitiException: Invalid reference in 'bpmnElement' attribute, process adhoc_One_Script_Task_Workflow not found | One_Script_Task_Workflow.bpmn20.xml | line 1 | column 1171

Can anybody explain me where is the problem?

Thanks in advance,
Alex

Outcomes