AnsweredAssumed Answered

Problem with autodeploy feature and 5.9

Question asked by aparraga on Mar 12, 2012
Latest reply on May 3, 2012 by heymjo
I did not noticed this error in 5.8, but in 5.9:

When I launched my development environment against a production database backup in 5.8 (and my environment in 5.9), the database was upgraded to 5.9 because I have activated the databaseSchemaUpdate property, BUT it crashes with a NULL Pointer Exception at this point:

java.lang.NullPointerException
   at org.activiti.engine.impl.cmd.DeployCmd.deploymentsDiffer(DeployCmd.java:72)
   at org.activiti.engine.impl.cmd.DeployCmd.execute(DeployCmd.java:50)
   at org.activiti.engine.impl.cmd.DeployCmd.execute(DeployCmd.java:30)

I have the deploymentResources for autodeploy new diagrams (amazing feature):
    <property name="deploymentResources" value="classpath:diagrams/*.bpmn20.xml" />        

So, the cause of the null pointer exception is that the DeployCmd at this point:

      ResourceEntity savedResource = savedResources.get(resourceName);
      if(!savedResource.isGenerated()) {

savedResource is null, reason is because the keys of the savedResources collection are different than the keys in the resources collection. The keys seems to be compounds by the paths + names of the bpmn files, and because paths are different in production and in my dev environment, it crashes.

When I was using the 5.8 with the backup of production 5.8 database, I do not remember this error.

So, I'm trying to figure out the reason, could anybody help me on that?

Thank you.

Outcomes