AnsweredAssumed Answered

issue with tomcat in the demo

Question asked by peted on Mar 25, 2012
Latest reply on Oct 10, 2012 by frederikheremans1
Hi,

After trying unsuccessfully for two hours to make the demo work for me, here's the detailed walkthrough of the problem;

1) brand new install (every time I encounter the problem) of activiti 5.9;
2) run ant demo.start from the setup folder;
3) I get full install with few warnings, but in the last step the browser page is loaded with 404 error:
Not Found

The requested URL /activiti-explorer was not found on this server.

(note its connecting at the default 8080 port)

4) looking at the tomcat logs I see the following error:


Mar 25, 2012 8:00:31 PM org.apache.coyote.http11.Http11Protocol init
SEVERE: Error initializing endpoint
java.net.BindException: Address already in use <null>:8080


5) checking with lsof -i -P reveals that this port is in fact not in use.
6) I've tried restarting cpl of times and starting from clean install to no avail;

My setup is as follows:

Mac OS X, 10.6.8

java -version:
java version "1.6.0_29"
Java(TM) SE Runtime Environment (build 1.6.0_29-b11-402-10M3527)
Java HotSpot(TM) 64-Bit Server VM (build 20.4-b02-402, mixed mode)

echo $JAVA_HOME:
/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/

I've tried few other values for $JAVA_HOME with outright exceptions or the same tomcat error. Incidentally, when $JAVA_HOME is empty it has the same outcome as the proper path shown above.

I can provide more detail if needed. May be it's my Mac's setup, but I don't want to continue fiddling with it. Any help is greatly appreciated since I'm keen to use Activiti as part of a much larger project which is aimed at serving a large industrial and academic base.

Thanks,

Pete

Outcomes