AnsweredAssumed Answered

no processes deployed with key

Question asked by zd251 on Apr 12, 2012
Latest reply on May 18, 2016 by jbarrez
I created my workflow and have the following code



       ProcessEngine processEngine = ProcessEngineConfiguration
                .createStandaloneInMemProcessEngineConfiguration()
                .buildProcessEngine();
      
      
        RuntimeService runtimeService = processEngine.getRuntimeService();
        RepositoryService repositoryService = processEngine.getRepositoryService();
        repositoryService.createDeployment()
                .addClasspathResource("diagrams/AlertingProcess.bpmn")
                .deploy();
                     
      processEngine.getRuntimeService().startProcessInstanceByKey("alertProcess");

This is my process


<process id="alertProcess" name="Alert Process">
    <startEvent id="startevent1" name="Start"></startEvent>
    <userTask id="assignedTask" name="AssignedTask"></userTask>
    <endEvent id="endevent1" name="End"></endEvent>
    <sequenceFlow id="flow1" name="" sourceRef="startevent1" targetRef="assignedTask"></sequenceFlow>
    <sequenceFlow id="flow2" name="" sourceRef="assignedTask" targetRef="endevent1"></sequenceFlow>
  </process>

I keep getting the following exception

Exception in thread "main" org.activiti.engine.ActivitiException: no processes deployed with key 'alertProcess'
at org.activiti.engine.impl.persistence.deploy.DeploymentCache.findDeployedLatestProcessDefinitionByKey(DeploymentCache.java:63)

I'm using Activiti version 5.9.

Any ideas?

Outcomes