AnsweredAssumed Answered

Karaf 2.2.7: Resource not found when trying to read the bpmn

Question asked by rajsenthil on May 30, 2012
Latest reply on Jun 8, 2012 by rajsenthil
Hi, I created a simple process with single script task "Hello Task" that prints out "Hello World". Ran it through the junit test and it worked.
Then I tried to bundle it and trying to run inside the karaf and getting "Caused by: org.activiti.engine.ActivitiException: resource 'HelloWorldProcess.bpmn' not found".

The Activiti engine bundle is installed in the karaf and successfully injected to the bundle.

Now I am trying to start that process by the code

                repositorySevice
                .createDeployment()   
                //.addClasspathResource("OSGI-INF/activiti/HelloWorldProcess.bpmn")
                //.addClasspathResource("/OSGI-INF/activiti/HelloWorldProcess.bpmn")
                .addClasspathResource("HelloWorldProcess.bpmn")
                .deploy();

But could never succeed to successfully read the file. I also dropped the HelloWorldProcess.bpmn under %KARAF_HOME%/etc folder and could not load it.

Please let me know what I am missing.

Also the DB that I am using is MySql 5.5 and could see the process definition in the table ACT_GE_BYTEARRAY. Is there any way to load the process from this table and start running it?

Thanks,
Senthil

Outcomes