AnsweredAssumed Answered

Activiti Modeler not working

Question asked by aejaz on Jul 4, 2012
Hi,

I am new to activiti & am trying to learn it. I have set up activiti
& am able to access activiti-explorer & activiti-rest applications.
But I am unable to use activiti-modeler which seems like a setup/
configuration issue. I keep getting the error "The application could
not be loaded. Please double check your internet connection and
reload the page." when I go to the URL http://localhost:8080/activiti-modeler
Here are the details of what I have done. Please let me know if
there is something I did incorrectly,

(I am on Windows 7 Enterprise x64),

- Downloaded activiti-5.9 from http://activiti.org/download.html
- Unzipped it in C:
- Setup ant & ran "ant h2.start" & "ant tomcat.start"
- Was able to connect to activiti-rest & activiti-explorer successfully from browser
- Also, downloaded the modeler code from http://signavio-core-components.googlecode.com/svn/trunk/ signavio-core-components-read-only & unzipped it in activiti-5.9
- Modified C:\activiti-5.9\signavio-core-components\build.properties (Contents below)
- Built activiti-modeler.war using "build-all-in-one-war" & copied it from target directory to C:\activiti-5.9\apps\apache-tomcat-6.0.32\webapps
- Restarted tomcat
- No console errors or deployment errors in tomcat logs while deploying activiti-modeler.war
- Went to http://localhost:8080/activiti-modeler from browser & got the error mentioned

No change in behavior.

Please let me know if anyone else is also seeing the same behavior & if so,
how did you resolve it.

Thanks,
Aejaz

———————————build.properties———————————
dir-tomcat-webapps = C:/activiti-5.9/apps/apache-tomcat-6.0.32/webapps
target = target
version=5.9
war = activiti-modeler
configuration = Activiti
host = http://localhost:8080
fileSystemRootDirectory = ../../../workspace/activiti-modeler-examples


#Tried with c:/activiti-5.9/workspace/activiti-modeler-examples as well, war gets
#deployed without errors but no change in behavior

Outcomes