AnsweredAssumed Answered

How to specify/increase termination timeout

Question asked by suribabu on Oct 31, 2012
Latest reply on Nov 5, 2012 by frederikheremans1
Hi,

I am new bee to Activiti BPM. When I am trying to start my process instance using

ProcessInstance processInstance = runtimeService.startProcessInstanceByKey("process1",map);

(this process includes many jobs run in parallel),
the process is getting terminated after 60 seconds without completing all my jobs. (see error msg below:)

org.activiti.engine.impl.jobexecutor.DefaultJobExecutor stopExecutingJobs
WARNING: Timeout during shutdown of job executor. The current running jobs could not end within 60 seconds after shutdown operation.


I did not set this time any where in config xml. If this is the default behavious, how can I change this?
Is there any parameter to increase this timeout ?
Please suggest.

Thanks in advance.

-Suri

Outcomes