AnsweredAssumed Answered

Money Task example, ActivitiUiUtil id error

Question asked by mark1 on Jan 10, 2013
Latest reply on Jan 11, 2013 by mark1
Hi

I'm new to Activiti and was trying out a couple of examples in the users guide.

I did successfully  create a simple workflow process using the Activiti Designer Eclipse plug-in and deployed it to the Activiti Explorer application.

When I tried to do the Money Task example I had a problem.

My current environment:

Activiti 5.11.1
Eclipse Juno
Activiti Designer Eclipse plug-in 5.11.1
    but in the POM it seems I have to specify 5.9.1


My Money Task compiles, and I can load it into a different Eclipse work space to try to use. The new Money Task shows up in the palette but when I try to add the task to a workflow it get errors. I can't actually add any tasks, because I always get the same error now.



java.lang.NullPointerException
    at org.activiti.designer.util.eclipse.ActivitiUiUtil.getNextId(ActivitiUiUtil.java:209)
    at org.activiti.designer.features.AbstractCreateBPMNFeature.getNextId(AbstractCreateBPMNFeature.java:58)
    at org.activiti.designer.features.AbstractCreateBPMNFeature.addObjectToContainer(AbstractCreateBPMNFeature.java:107)
    at org.activiti.designer.features.AbstractCreateBPMNFeature.addObjectToContainer(AbstractCreateBPMNFeature.java:161)
    at org.activiti.designer.features.CreateServiceTaskFeature.create(CreateServiceTaskFeature.java:45)
    at org.eclipse.graphiti.features.impl.AbstractCreateFeature.execute(AbstractCreateFeature.java:100)
    at org.eclipse.graphiti.internal.command.GenericFeatureCommandWithContext.execute(GenericFeatureCommandWithContext.java:64)
    at org.eclipse.graphiti.internal.command.GFPreparableCommand.doExecute(GFPreparableCommand.java:37)
    at org.eclipse.emf.transaction.RecordingCommand.execute(RecordingCommand.java:135)
    at org.eclipse.graphiti.ui.internal.editor.GFWorkspaceCommandStackImpl.execute(GFWorkspaceCommandStackImpl.java:102)
    at org.eclipse.emf.transaction.impl.AbstractTransactionalCommandStack.execute(AbstractTransactionalCommandStack.java:219)
    at org.eclipse.graphiti.internal.command.CommandExec.executeCommand(CommandExec.java:86)
    at org.eclipse.graphiti.ui.internal.command.CreateModelObjectCommand.execute(CreateModelObjectCommand.java:54)
    at org.eclipse.graphiti.ui.internal.editor.EmfOnGefCommand.execute(EmfOnGefCommand.java:54)

etc…

Thanks

Outcomes